
  






<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.kimt.com/content/tncms/live/" />
<meta name="tncms-access-version" content="" />
<meta name="keywords" content="rochester, church, fire, arson, peace united, tips, police, information" />
<meta name="news_keywords" content="rochester, church, fire, arson, peace united, tips, police, information" />
<meta name="description" content="April fire caused over $2 million in damage." />
<meta name="author" content="Mike Bunge" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?crop=1549%2C813%2C27%2C0&amp;resize=1200%2C630&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Public asked to help solve Rochester church arson" />
<meta property="og:description" content="April fire caused over $2 million in damage." />
<meta property="og:site_name" content="KIMT News 3" />
<meta property="og:section" content="News" />
<meta property="article:publisher" content="https://www.facebook.com/KIMTNews3" />
<meta name="twitter:image" content="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?crop=1549%2C813%2C27%2C0&amp;resize=438%2C230&amp;order=crop%2Cresize" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@KIMTNews3" />
<meta name="twitter:image:alt" content="Rochester Fire Department" />
<meta property="tncms:ads" content="smart,lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.c58a1beaa3640fa94c3db09673c4d95c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.496f084a596de555cc076783bc05ddcb.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.0108c185ef3be15eaa06171a72c7f0cb.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css2?family=Roboto:wght@300;400;500;700;900&amp;family=STIX+Two+Text:wght@400;500;600;700&amp;family=Roboto+Condensed:wght@400;700&amp;display=swap"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-button.52347555fbb6668223efabadb9c9d111.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.61.6"},"crm":{"group_id":"814"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"centerpiece","style":"default","path":"\/news","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"type":"article","author":"Mike Bunge","start_hour":"18","id":"d42c8e50-cff3-11ec-b72f-8b5d626a1300","app":"editorial","ga_page":"\/news\/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":319},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-54612925-14"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://tags.crwdcntrl.net/c/16305/cc.js?ns=_cc16305" id="LOTCC_16305"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc16305.add('tp', 'TNNW');
		_cc16305.add('act', ' User Login');
		_cc16305.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc16305.bcp();
</script>

<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.f3739bd4d04bcee9e077d20b4f31f29c.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};

    __tnt.ads.dfp.targeting.asset_id = 'd42c8e50-cff3-11ec-b72f-8b5d626a1300';
    __tnt.ads.dfp.targeting.k = ["rochester","church","fire","arson","peace united","tips","police","information"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        cube:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/cube.d862aac30e9cb24516c7474509403c47.js",
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/interstitial.df40f87de692498682823c6773da5459.js",
        nativeArticle:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/paw.9ea074ccc913cb273a4b790e1e37460a.js",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/pencil.2662e4159cdac4809283c5399d78644b.js",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        roller:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/roller.c699c542afb9f08b38613e8473ddf14f.js",
        slider:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/slider.015001bff591d1665c6d0ec2a888b1ca.js",
        stickyAnchor:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/sticky-anchor.6dc181cbc3d60e2a1892d05998349ef6.js",
        video:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/kimt.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22591738783/kimt.com/news';
            
                gptAdSlots['ad-1142322'] = googletag.defineSlot(adUnit, [2, 1], 'ad-1142322').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1142322'].setTargeting('pos', ['impact-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22591738783/kimt.com/news';
            
                gptAdSlots['ad-1142355'] = googletag.defineSlot(adUnit, [1, 1], 'ad-1142355').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1142355'].setTargeting('pos', ['sticky-anchor','impact-sticky-anchor','sticky-footer','impact-sticky-footer']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22591738783/kimt.com/news';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [[728, 90], [320,50]]).addSize([992, 0], [[970, 90], [728, 90], [970, 250]]).addSize([1200, 0], [[1170, 90], [970, 90], [728, 90], [970, 250]]).build();
                gptAdSlots['ad-1142298'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,90],[970,250],[1170,90]], 'ad-1142298').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1142298'].setTargeting('pos', ['leaderboard-one']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.openweb.sso.04a3313763142f372f05a1bf3f7a47ba.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Public asked to help solve Rochester church arson | News | kimt.com</title>
            
    <style>body { background-color: #ffffff; color: #222; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #000; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1366px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #fff; } .fixed-nav #main-navigation { background-color: #fff !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer-container, #site-footer { background-color: #efefef; color: #595959; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus, .navbar-default .navbar-nav>li>button.nav-link, .navbar-default .navbar-nav>li>button.nav-link:hover, .navbar-default .navbar-nav>li>button.nav-link:focus, .navbar-default .navbar-nav>.open>button.nav-link, .navbar-default .navbar-nav>.open>button.nav-link:hover, .navbar-default .navbar-nav>.open>button.nav-link:focus{ color: #222; } .navbar-toggle .icon-bar { background-color: #222 !important; } .navbar-toggle .sr-only-show { color: #222 !important; } #site-top-nav .list-inline>li>a { color: #222; } .asset .asset-body p, .asset #asset-content p { color: #222; }@media (min-width: 1200px) { .container { width: 100%; } } @media (min-width: 1396px) { .container.has-wallpaper, .has-wallpaper .container, .container { width: 1366px; } } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-bottom-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #222; } }#site-top-nav .list-inline>li>a.btn:not(.btn-link) { color: #fff; }#site-copyright a, #site-footer a { color: #000; }.search-redesign .top-breakout > .row { max-width: 1366px; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #801719; }#site-header-container{ border-bottom: 3px solid #801719; }#site-footer-container{ border-top: 3px solid #801719; } .tnt-bg-accent { background-color: #801719; } a .tnt-caret-down { color: #801719; } .block-title .block-title-inner { border-color: #801719; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #801719; } .form-control:focus { border-bottom-color: #801719; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.kimt.com/content/tncms/site/icon.ico" />
    
        <link rel="amphtml" href="https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.amp.html" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Public asked to help solve Rochester church arson | News | kimt.com" href="http://www.kimt.com/search/?f=rss&amp;t=article&amp;c=news&amp;l=50&amp;s=start_time&amp;sd=desc" />
    
    <link rel="canonical" href="https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" />
    
            <script defer src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.46a248d75dc687aa8d928092f6b77fc7.js"></script>
            <script language="javascript" type="text/javascript">
$(document).ready(function() {       

     $('.add-weather-link .weather-now-container').prepend('<a href="/weather" class="weather-extra-link"></a>');
        

}); 
</script>

<!--NATIVO SCRIPT(all pages) - added 09/20/2021-->
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
 
<!--NATIVO SCRIPT(only landing page)-->

<!--/NATIVO SCRIPTS-->


<!-- connatix -->
<script>!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);</script>
<!-- end connatix -->


 <script src="//d3plfjw9uod7ab.cloudfront.net/6039a864-9622-4b9e-bf48-ec943f27297b.js" type="text/javascript"></script>


        </head>
        <body class="fixed-scroll-nav app-editorial grid-centerpiece blox-asset uuid-d42c8e50-cff3-11ec-b72f-8b5d626a1300  section-news type-article infinity-disabled" data-authors='[]' data-path="/news">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.kimt.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.61.6&amp;townnews.crm.group_id=814&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=centerpiece&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.type=article&amp;tncms.asset.author=Mike+Bunge&amp;tncms.asset.start_hour=18&amp;tncms.asset.id=d42c8e50-cff3-11ec-b72f-8b5d626a1300&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fnews%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=319&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.google.ua=UA-54612925-14&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-contribute-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-certificate tnt-fw"></i></div>
                <div class="asset-edit-message">You are the owner of this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" href="https://www.kimt.com/users/admin/contribute/article/?assetid=d42c8e50-cff3-11ec-b72f-8b5d626a1300&assettype=article"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit Article</a>
                    
                        <a class="btn btn-danger btn-sm" href="https://www.kimt.com/users/admin/contribute/article/?from_section=/news"><i class="fas tnt-plus tnt-fw"></i> Add New Article</a>
                    
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.kimt.com/tncms/admin/editorial-asset/?edit=d42c8e50-cff3-11ec-b72f-8b5d626a1300"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left" aria-label="Left Main Menu" aria-expanded="false" tabindex="-1" >
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-1142700" class="tncms-block in-drawer nav-logo"><div id="site-logo-1142700" class="site-logo-container text-center" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/396adf3a-38e4-11ec-bb03-bbc861e46da3.png?resize=200%2C45" 
            srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/396adf3a-38e4-11ec-bb03-bbc861e46da3.png?resize=150%2C34 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/396adf3a-38e4-11ec-bb03-bbc861e46da3.png?resize=200%2C45 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/396adf3a-38e4-11ec-bb03-bbc861e46da3.png?resize=225%2C51 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/396adf3a-38e4-11ec-bb03-bbc861e46da3.png?resize=300%2C68 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/396adf3a-38e4-11ec-bb03-bbc861e46da3.png?resize=400%2C91 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/396adf3a-38e4-11ec-bb03-bbc861e46da3.png?resize=540%2C123 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/396adf3a-38e4-11ec-bb03-bbc861e46da3.png?resize=640%2C145 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/396adf3a-38e4-11ec-bb03-bbc861e46da3.png?resize=750%2C170 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/396adf3a-38e4-11ec-bb03-bbc861e46da3.png 990w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="858"
            height="195"
            alt="site-logo"
            ></a>
        </div></div></div><div id="tncms-block-1142697" class="tncms-block in-drawer social-links"><div class="follow-links-1142697 default">
    
    <section id="block-1142697" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/KIMTNews3" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/KIMTNews3" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.kimt.com",
  "sameAs" : ["https://www.facebook.com/KIMTNews3","https://twitter.com/KIMTNews3"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-1142349" class="tncms-block hidden-md hidden-lg"><section id="block-1142349" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1142349" class="search-form-container card clearfix text-center hidden-print well">
    <form id="site-search-1142349" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-1142349" class="site-search-form input-group default normal ">
        <label for="site-search-1142349-term" class="sr-only">Site search</label>
        <input id="site-search-1142349-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1142349-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	            
                <span id="site-search-button-1142349" class="hidden-xs hidden-sm ">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section></div><div id="tncms-block-1142352" class="tncms-block hidden-lg hidden-md in-drawer"><div id="user-controls-1142352" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li>
                    <a href="https://www.kimt.com/users/signup/?referer_url=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">
                        Sign Up
                    </a>
                </li><li>
                    <a href="https://www.kimt.com/users/login/?referer_url=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li>
                        <a href="https://www.kimt.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">
                            Dashboard
                        </a>
                    </li>
                    <li>
                        <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1142352').submit(); return false;" rel="nofollow">
                            Logout
                        </a>
                    </li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.kimt.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.kimt.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.kimt.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-1142352').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.kimt.com/users/logout/" id="user-logout-form-1142352"><input type="hidden" name="referer_url" value="https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home ">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/search/"  class="nav-link tnt-section-search ">Search</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/news/"  class="nav-link tnt-section-news ">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/local/"  class="nav-link tnt-section-local">Local</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/iowa/"  class="nav-link tnt-section-iowa">Iowa</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/minnesota/"  class="nav-link tnt-section-minnesota">Minnesota</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/coronavirus/"  class="nav-link tnt-section-coronavirus">Coronavirus</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/crime/"  class="nav-link tnt-section-crime-courts">Crime & Courts</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/politics/"  class="nav-link tnt-section-politics">Politics</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/cerro-gordo-county/"  class="nav-link tnt-section-cerro-gordo-county">Cerro Gordo County</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/freeborn-mower-counties/"  class="nav-link tnt-section-freebornmower-counties">Freeborn/Mower counties</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/olmsted-county/"  class="nav-link tnt-section-olmsted-county">Olmsted County</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/national/"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/national-livestream/"  class="nav-link tnt-section-national-news-livestream">National News Livestream</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/health/"  class="nav-link tnt-section-health">Health</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/special-reports/"  class="nav-link tnt-section-special-reports">Special Reports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/traffic/"  class="nav-link tnt-section-traffic-maps-cams">Traffic Maps & Cams</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/traffic/map/"  class="nav-link tnt-section-live-traffic">Live Traffic</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/ag-news/"  class="nav-link tnt-section-ag-news">Ag News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/how-to-watch/"  class="nav-link tnt-section-how-to-watch">How To Watch</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/submitanewstip"  class="nav-link tnt-section-submit-a-news-tip">Submit A News Tip</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/contact/email/"  class="nav-link tnt-section-sign-up-for-email-alerts">Sign Up For Email Alerts</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/weather/"  class="nav-link tnt-section-weather ">Weather</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather/interactive-radar/"  class="nav-link tnt-section-interactive-radar">Interactive Radar</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather/maps-radars/"  class="nav-link tnt-section-maps-radars">Maps & Radars</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather/alerts/"  class="nav-link tnt-section-alerts">Alerts</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather/closings/"  class="nav-link tnt-section-closings">Closings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/traffic/"  class="nav-link tnt-section-traffic-maps-cams">Traffic Maps & Cams</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather/submit-closings/"  class="nav-link tnt-section-submit-closings">Submit Closings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather/submit-photos/"  class="nav-link tnt-section-submit-weather-photos">Submit Weather Photos</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather/eye-in-the-sky/"  class="nav-link tnt-section-live-eye-tower-cams">Live Eye - Tower Cams</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather/weather-safety/"  class="nav-link tnt-section-weather-safety">Weather Safety</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/contact/apps/"  class="nav-link tnt-section-weather-app">Weather App</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/sports"  class="nav-link tnt-section-sports ">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/local/"  class="nav-link tnt-section-local-sports">Local Sports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/national/"  class="nav-link tnt-section-national-sports">National Sports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/student-athlete-of-the-week/"  class="nav-link tnt-section-student-athlete-of-the-week">Student Athlete Of The Week</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/outdoors/"  class="nav-link tnt-section-kimt-outdoors">KIMT Outdoors</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/video/"  class="nav-link tnt-section-video ">Video</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/livestream/"  class="nav-link tnt-section-kimt-livestream">KIMT Livestream</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/national-livestream/"  class="nav-link tnt-section-cbsn-livestream">CBSN Livestream</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/video/"  class="nav-link tnt-section-on-demand">On Demand</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.youtube.com/channel/UCgiFbHIm6SzfF_lo7d98jUg"  target="_blank" rel="noopener" class="nav-link tnt-section-youtube">YouTube</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/contact/apps/"  class="nav-link tnt-section-tv-apps">TV Apps</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/video/tv-listings/"  class="nav-link tnt-section-tv-listings">TV Listings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://www.mynetworktv.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-my-network-tv">My Network TV</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-7" data-target="#mobile-nav-left_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/community/"  class="nav-link tnt-section-community ">Community</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/giving-your-best/"  class="nav-link tnt-section-giving-your-best">Giving Your Best</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/tools-for-schools/"  class="nav-link tnt-section-tools-for-schools">Tools for Schools</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/calendar/"  class="nav-link tnt-section-community-calendar">Community Calendar</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/contests/"  class="nav-link tnt-section-contests">Contests</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://deals.allenmediabroadcasting.com/index.php?mact=AMBDeals,cntnt01,viewDeal,0&amp;cntnt01dealID=38&amp;cntnt01returnid=46"  target="_blank" rel="noopener" class="nav-link tnt-section-kimt-job-fair">KIMT Job Fair</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/non-profits/"  class="nav-link tnt-section-non-profit-of-the-month">Non-Profit of the Month</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/contact/"  class="nav-link tnt-section-contact ">Contact</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/contact/meet-the-team/"  class="nav-link tnt-section-meet-the-news-team">Meet The News Team</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/contact/sales-team/"  class="nav-link tnt-section-management-sales">Management & Sales</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/contact/history/"  class="nav-link tnt-section-history">History</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://allenmediabroadcasting.com/careers/kimt.html"  target="_blank" rel="noopener" class="nav-link tnt-section-kimt-careers">KIMT Careers</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/contact/about/"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/contact/advertise/"  class="nav-link tnt-section-digital-marketing">Digital Marketing</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/contact/email/"  class="nav-link tnt-section-email-alerts">Email Alerts</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/contact/apps/"  class="nav-link tnt-section-our-apps">Our Apps</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="https://deals.allenmediabroadcasting.com/kimt.html"  target="_blank" rel="noopener" class="nav-link tnt-section-deals ">Deals</a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-1142322" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1142322" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1142322');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1142355" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1142355" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1142355');
                        
                });
            </script>
        </div>
    </div>
</div></div>
    

    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1142754" class="tncms-block"><div id="moved-trigger"><button type="button" class=" hamburger-desktop fluid-header navbar-toggle pull-left" data-toggle="offcanvas" data-target="left" aria-label="Left Main Menu" aria-expanded="false">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button></div></div><div id="tncms-block-1142328" class="tncms-block header-search"><ul id="site-search-1142328-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown" aria-label="Search">
                <span class="fas tnt-search"></span>
            </a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1142328" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-1142328" class="site-search-form input-group default normal ">
        <label for="site-search-1142328-term" class="sr-only">Site search</label>
        <input id="site-search-1142328-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1142328-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	            
                <span id="site-search-button-1142328" class="hidden-xs hidden-sm ">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
</div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1142343" class="tncms-block"><div id="site-logo-1142343" class="site-logo-container text-center" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/3f42dcbc-38cd-11ec-bb03-97048901fb69.png?resize=200%2C45" 
            srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/3f42dcbc-38cd-11ec-bb03-97048901fb69.png?resize=150%2C34 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/3f42dcbc-38cd-11ec-bb03-97048901fb69.png?resize=200%2C45 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/3f42dcbc-38cd-11ec-bb03-97048901fb69.png?resize=225%2C51 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/3f42dcbc-38cd-11ec-bb03-97048901fb69.png?resize=300%2C68 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/3f42dcbc-38cd-11ec-bb03-97048901fb69.png?resize=400%2C91 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/3f42dcbc-38cd-11ec-bb03-97048901fb69.png?resize=540%2C123 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/3f42dcbc-38cd-11ec-bb03-97048901fb69.png?resize=640%2C145 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/3f42dcbc-38cd-11ec-bb03-97048901fb69.png?resize=750%2C170 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/3f42dcbc-38cd-11ec-bb03-97048901fb69.png 990w"
            sizes="(min-width: 1396px) 455px, calc(33.33vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="858"
            height="195"
            alt="site-logo"
            ></a>
        </div></div></div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1142337" class="tncms-block header-weather"><div id="weather-1142337" class="weather-current size-small pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions ">
            <a href="/weather/?weather_zip=50401" class="dropdown-toggle"  aria-label="Weather">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-day-sunny-overcast"></span>
                </span>
                <span class="pull-left temp-desc small">
                    <span class="temp">86&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" aria-label="Main" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop fluid-header navbar-toggle pull-left" data-toggle="offcanvas" data-target="left" aria-label="Left Main Menu" aria-expanded="false">
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                         
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1142325" class="tncms-block"><div id="site-logo-1142325" class="site-logo-container text-center" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/55d54720-3b2b-11ec-8535-777b0b646494.png?resize=200%2C67" 
            srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/55d54720-3b2b-11ec-8535-777b0b646494.png?resize=150%2C50 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/55d54720-3b2b-11ec-8535-777b0b646494.png?resize=200%2C67 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/55d54720-3b2b-11ec-8535-777b0b646494.png?resize=225%2C75 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/55d54720-3b2b-11ec-8535-777b0b646494.png 300w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="300"
            height="100"
            alt="site-logo"
            ></a>
        </div></div></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown" aria-label="Search">
                                    <span class="fas tnt-search"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });
                        </script>
                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1142331" class="tncms-block header-user"><div id="user-controls-1142331" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="nav navbar-nav navbar-right"><li><a  onclick="javascript:void(0); return false;"  data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" class="user-control-link" rel="nofollow">
                        <span class="fas tnt-user"></span>
                        <span class="sr-only">Open user controls</span>
                    </a>
                    <ul class="dropdown-menu dropdown-menu-right" role="menu">
                        <li>
                            <div style="width: 300px; padding: 15px">
                                <div class="row padding-bottom">
                                    <div class="col-md-12">
                                        <h4>Log In Using Your Account</h4>
                                        <a role="menuitem" class="btn btn-block btn-primary" href="https://www.kimt.com/users/login/?referer_url=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" rel="nofollow">Log In</a>
                                    </div>
                                </div>
                                <div class="row">
                                    <div class="col-md-12">
                                        <div class="dropdown-signup"><strong>Don't have an account?</strong> <a role="menuitem" href="https://www.kimt.com/users/signup/?referer_url=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" rel="nofollow">Sign Up Today</a></div>
                                    </div>
                                </div>
                            </div>
                        </li>
                    </ul>
                </li>
        </ul>
    </div>

    <div class="logged-in">
        
        
        <ul class="nav navbar-nav navbar-right">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.kimt.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.kimt.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.kimt.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-1142331').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.kimt.com/users/logout/" id="user-logout-form-1142331"><input type="hidden" name="referer_url" value="https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1142340" class="tncms-block nav-social"><div class="follow-links-1142340 pull-right">
    
    <section id="block-1142340" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/KIMTNews3" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/KIMTNews3" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.kimt.com",
  "sameAs" : ["https://www.facebook.com/KIMTNews3","https://twitter.com/KIMTNews3"]
}
</script>
<div class="clearfix"></div></div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link    tnt-section-news"  href="/news"  tabindex="0" >
                    <span class="nav-label ">News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-weather"  href="/weather/"  tabindex="0" >
                    <span class="nav-label ">Weather</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sports"  href="/sports"  tabindex="0" >
                    <span class="nav-label ">Sports</span>
                </a></li><li>
                <a class="nav-link    tnt-section-video"  href="/video/"  tabindex="0" >
                    <span class="nav-label ">Video</span>
                </a></li><li>
                <a class="nav-link    tnt-section-community"  href="https://www.kimt.com/community/"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Community</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact-us"  href="/contact/"  tabindex="0" >
                    <span class="nav-label ">Contact Us</span>
                </a></li><li>
                <a class="nav-link    tnt-section-deals"  href="https://deals.allenmediabroadcasting.com/kimt.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Deals</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        

<div class="fullscreen-region"><div id="tncms-region-global-container-trending-fullscreen" class="tncms-region "><div id="tncms-block-1142772" class="tncms-block"><div class="live_trending">
    <ul class="list-inline">
        <li><strong>GAS TRACKER</strong></li>
        
        <li><a href="https://www.kimt.com/news/local/gas-tracker-the-latest-average-prices-of-gas-by-county-in-the-area/article_378acd86-b6a4-11ec-b417-27b35e070ff8.html">Prices by county</a></li>
        
        
        
                    
    </ul>
</div></div><div id="tncms-block-1142778" class="tncms-block"><div class="live_trending">
    <ul class="list-inline">
        <li><strong>JOIN IN</strong></li>
        
        <li><a href="https://www.kimt.com/community/contests/join-in-kimts-senior-yearbook/html_51e7ff06-bcd9-11ec-935f-9f2bf2fd284b.html">KIMT's Senior Yearbook</a></li>
        
        
        
                    
    </ul>
</div></div></div></div>

        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1142298" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1142298" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1142298');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1142295" class="tncms-block padding-top padding-bottom allen-breaking"></div><div id="tncms-block-1142835" class="tncms-block weather-alert"></div><div id="tncms-block-1142859" class="tncms-block"><script>
$(document).ready(function(){
  $.ajaxSetup({ cache: false });
    $.getJSON("https://amb-feeds.s3.amazonaws.com/KIMT_closings.json", function(result){
		var numClosings = result.numClosings;
		var title = result.title;
		var closingsURL = result.closingsURL;

		var closingsString =  title + ' ' + '<a style="color:yellow" href=' + closingsURL + '>View All';	
		
		if(numClosings > 0){
		    $('#closings').css({'display':'block'});
            $('#closings').css({'color': '#ffffff'});
			$('#closings').css({'padding': '10px'});
            $('#closings').css({'margin': '0px 0px 15px 0px'});
            $('#closings').css({'background-color':'#022B9C'});
            $('#closings').css({'font-size':'12pt'});
            $('#closings').css({'font-weight':'bold'});
			document.getElementById("closings").innerHTML = closingsString;
		}
  });
});
</script><div id="closings" style="display:none"></div></div><div id="tncms-block-1142868" class="tncms-block"><script>
$(document).ready(function(){
  $.ajaxSetup({ cache: false });
    $.getJSON("https://amb-feeds.s3.amazonaws.com/KIMT_livestream.json", function(data){
		
		var streamTitle = data.title;
		var streamURL= '/livestream';
		var streamName = data.streamName

		var streamString=  streamName + ' ' + '<a style="color:#000000" href=' + streamURL+ '>Watch Now';	
		console.log(streamString);
		if(streamTitle != ''){
		    $('#livestream').css({'display':'block'});
            $('#livestream').css({'color': '#000000'});
			$('#livestream').css({'padding': '10px'});
            $('#livestream').css({'margin': '0px 0px 15px 0px'});
            $('#livestream').css({'background-color':'#ffbe00'});
            $('#livestream').css({'font-size':'14pt'});
            $('#livestream').css({'font-weight':'bold'});
			document.getElementById("livestream").innerHTML = streamString;
		}
  });
});
</script><div id="livestream" style="display:none"></div></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "></div></div>
        </div><div id="modal-image-54448c8a-ae1d-11ec-83a7-534c2f161c72" class="modal fullscreen in modal-image image-default modal-54448c8a-ae1d-11ec-83a7-534c2f161c72" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-blur">
            <div class="image" 
                >
                
                
                
                <img
                        src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=400%2C203"
                        srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=150%2C76 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=200%2C101 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=225%2C114 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=300%2C152 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=400%2C203 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=540%2C274 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=640%2C325 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=750%2C380 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=990%2C502 990w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1035%2C525 1035w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1200%2C609 1200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1333%2C676 1333w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1476%2C749 1476w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1603%2C813 2008w"
                        sizes="100vw"
                        
                        width="1603"
                        height="813"
                        alt="Rochester Fire Department"
                        class="img-responsive true-size blur" />
                
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=200%2C101" alt="" aria-hidden="true" loading="lazy" height="101" width="200"/>
         </div>
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-54448c8a-ae1d-11ec-83a7-534c2f161c72" data-target=".caption-inner-modal-image-54448c8a-ae1d-11ec-83a7-534c2f161c72">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-54448c8a-ae1d-11ec-83a7-534c2f161c72 collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.kimt.com%2Frochester-fire-department%2Fimage_54448c8a-ae1d-11ec-83a7-534c2f161c72.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/rochester-fire-department/image_54448c8a-ae1d-11ec-83a7-534c2f161c72.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"54448c8a-ae1d-11ec-83a7-534c2f161c72"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Rochester%20Fire%20Department&via=KIMTNews3&url=https%3A%2F%2Fwww.kimt.com%2Frochester-fire-department%2Fimage_54448c8a-ae1d-11ec-83a7-534c2f161c72.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/rochester-fire-department/image_54448c8a-ae1d-11ec-83a7-534c2f161c72.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"54448c8a-ae1d-11ec-83a7-534c2f161c72"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.kimt.com/rochester-fire-department/image_54448c8a-ae1d-11ec-83a7-534c2f161c72.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/rochester-fire-department/image_54448c8a-ae1d-11ec-83a7-534c2f161c72.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"54448c8a-ae1d-11ec-83a7-534c2f161c72"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.kimt.com/tncms/asset/editorial/54448c8a-ae1d-11ec-83a7-534c2f161c72" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"54448c8a-ae1d-11ec-83a7-534c2f161c72"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BAllen%20Media%20Broadcasting%5D%20Rochester%20Fire%20Department&body=https%3A%2F%2Fwww.kimt.com%2Frochester-fire-department%2Fimage_54448c8a-ae1d-11ec-83a7-534c2f161c72.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"54448c8a-ae1d-11ec-83a7-534c2f161c72"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/rochester-fire-department/image_54448c8a-ae1d-11ec-83a7-534c2f161c72.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"54448c8a-ae1d-11ec-83a7-534c2f161c72"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-54448c8a-ae1d-11ec-83a7-534c2f161c72-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="54448c8a-ae1d-11ec-83a7-534c2f161c72" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="54448c8a-ae1d-11ec-83a7-534c2f161c72" class="save-list-54448c8a-ae1d-11ec-83a7-534c2f161c72-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="54448c8a-ae1d-11ec-83a7-534c2f161c72" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-54448c8a-ae1d-11ec-83a7-534c2f161c72 img { max-height: 813px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-d42c8e50-cff3-11ec-b72f-8b5d626a1300" class="asset article-longform" data-url="https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="<p>April fire caused over $2 million in damage.</p>"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?crop=1549%2C813%2C27%2C0&resize=1200%2C630&order=crop%2Cresize">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="kimt.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" />
    <style>
                .asset-paging .direction {
                    color: #801719;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.kimt.com\/tncms\/search\/mlt\/?origin=d42c8e50-cff3-11ec-b72f-8b5d626a1300&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-d42c8e50-cff3-11ec-b72f-8b5d626a1300" class="asset-paging">
                <div id="paging-prev-d42c8e50-cff3-11ec-b72f-8b5d626a1300" class="paging-link prev offset"></div>
                <div id="paging-next-d42c8e50-cff3-11ec-b72f-8b5d626a1300" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead text-center">
        <header class="asset-header">
    <div class="tow-wrapper no-flags">
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            Public asked to help solve Rochester church arson
        </span>
    </h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-fe1dfbca-52cd-11ec-819f-bf296f1d62ea-asset-d42c8e50-cff3-11ec-b72f-8b5d626a1300" class="tnt-byline asset-byline" rel="popover" itemprop="author"><a href="https://www.kimt.com/users/profile/Mike%20Bunge">By Mike Bunge</a></span>
                
                    <div id="author-popup-fe1dfbca-52cd-11ec-819f-bf296f1d62ea-asset-d42c8e50-cff3-11ec-b72f-8b5d626a1300-content" class="hide">
                        <article class="clearfix card author popup-content card-author-fe1dfbca-52cd-11ec-819f-bf296f1d62ea">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.kimt.com/users/profile/Mike%20Bunge" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        <img alt="Mike Bunge" src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/avatars/f/e1/dfb/fe1dfbca-52cd-11ec-819f-bf296f1d62ea.f7bcef65eaa8b907ca68bc3f524912bd.png?_dc=1638380544" width="200" height="200" loading="lazy" class="img-responsive lazyload tnt-user-avatar" />
                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.kimt.com/users/profile/Mike%20Bunge" rel="author" class="tnt-user-profile-link tnt-user-name">Mike Bunge</a>
                                </h4><p class="tnt-user-title small text-muted">Assignment Editor</p>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:mbunge@kimt.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-fe1dfbca-52cd-11ec-819f-bf296f1d62ea-asset-d42c8e50-cff3-11ec-b72f-8b5d626a1300').popover({
                            content: $('#author-popup-fe1dfbca-52cd-11ec-819f-bf296f1d62ea-asset-d42c8e50-cff3-11ec-b72f-8b5d626a1300-content').html(),
                            container: 'body',
                            html:true,
                            sanitize: false,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li class="visible-print">
        <time datetime="2022-05-09T18:57:00-05:00" class="tnt-date asset-date text-muted">
            May 9, 2022
        </time></li>
            <li class="hidden-print"><time datetime="2022-05-09T18:57:00-05:00" class="tnt-date asset-date text-muted">May 9, 2022</time>
        <span class="text-muted tnt-update-recent">Updated </span>
        <time datetime="2022-05-09T19:01:42-05:00" class="tnt-date tnt-update-recent asset-date text-muted">23 min ago</time>
    </li>
        
        
            <li class="hidden-print"><a href="https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html#comments" class="cm">
            <span class="fas tnt-comments"></span> 
            <span id="openWeb-count-d42c8e50-cff3-11ec-b72f-8b5d626a1300" twt-comment-count="https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" twt-article-id="d42c8e50-cff3-11ec-b72f-8b5d626a1300">0</span>
        </a>
        <script type="text/javascript">
            fetch("https://open-api.spot.im/v1/messages-count?spot_id=sp_c8670lg9&posts_ids=d42c8e50-cff3-11ec-b72f-8b5d626a1300")
                .then(function(response) {
                    return response.json();
                })
                .then(function(openWeb) {
                    if (openWeb && openWeb.messages_count) {
                        document.getElementById("openWeb-count-d42c8e50-cff3-11ec-b72f-8b5d626a1300").innerHTML = openWeb.messages_count['d42c8e50-cff3-11ec-b72f-8b5d626a1300'];
                        document.querySelectorAll(".comment-counter").forEach(function(e) { 
                            e.innerHTML = openWeb.messages_count['d42c8e50-cff3-11ec-b72f-8b5d626a1300'];
                        });
                    }
                });
        </script></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-05-09T18:57:00-05:00">
    <meta itemprop="datePublished" content="2022-05-09T18:57:00-05:00">
    <meta itemprop="dateModified" content="2022-05-09T14:01:42-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs">
                <ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Public%20asked%20to%20help%20solve%20Rochester%20church%20arson&via=KIMTNews3&url=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.kimt.com/tncms/asset/editorial/d42c8e50-cff3-11ec-b72f-8b5d626a1300" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BAllen%20Media%20Broadcasting%5D%20Public%20asked%20to%20help%20solve%20Rochester%20church%20arson&body=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
            </div>
        
    </div>

    

    <div class="row">
        <div class="col-md-offset-1 col-md-10">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-blur"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-54448c8a-ae1d-11ec-83a7-534c2f161c72" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-54448c8a-ae1d-11ec-83a7-534c2f161c72" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1603">
            <meta itemprop="height" content="813">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1396%2C708">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1396%2C708"><img
                        src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=400%2C203"
                        srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=150%2C76 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=200%2C101 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=225%2C114 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=300%2C152 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=400%2C203 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=540%2C274 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=640%2C325 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=750%2C380 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=990%2C502 990w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1035%2C525 1035w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1200%2C609 1200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1333%2C676 1333w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1476%2C749 1476w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=1603%2C813 2008w"
                        sizes="(min-width: 1396px) 1366px, calc(100vw - 30px)"
                        
                        width="1603"
                        height="813"
                        alt="Rochester Fire Department"
                        class="img-responsive full tnt-restrict-img-54448c8a-ae1d-11ec-83a7-534c2f161c72 blur" />
            </div><style>
                .tnt-restrict-img-54448c8a-ae1d-11ec-83a7-534c2f161c72 {
                    max-width: 1603px;
                }
            </style>
                
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/44/54448c8a-ae1d-11ec-83a7-534c2f161c72/6240e549a8ba8.image.jpg?resize=200%2C101" alt="" aria-hidden="true" loading="lazy" height="101" width="200"/>
         </div>
            </div>
            
                
                
            
        </figure></div><div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="d42c8e50-cff3-11ec-b72f-8b5d626a1300" data-smart-adunit="/132916964,22591738783/kimt.com/news">

                

                <div class="row">

                    <div class="col-lg-12 col-md-12">

                        <div class="asset-body">
                            
                                <div class="share-container content-above"><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Public%20asked%20to%20help%20solve%20Rochester%20church%20arson&via=KIMTNews3&url=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.kimt.com/tncms/asset/editorial/d42c8e50-cff3-11ec-b72f-8b5d626a1300" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BAllen%20Media%20Broadcasting%5D%20Public%20asked%20to%20help%20solve%20Rochester%20church%20arson&body=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-d42c8e50-cff3-11ec-b72f-8b5d626a1300-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="d42c8e50-cff3-11ec-b72f-8b5d626a1300" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="d42c8e50-cff3-11ec-b72f-8b5d626a1300" class="save-list-d42c8e50-cff3-11ec-b72f-8b5d626a1300-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="d42c8e50-cff3-11ec-b72f-8b5d626a1300" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div id="article-body"  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>ROCHESTER, Minn. – Investigators are asking for the public’s help in solving a church fire. </p><p>The Rochester Police Department (RPD) says the <a href="https://www.kimt.com/video/peace-united-church-of-christ-catches-fire/video_80162ba9-0f5c-5203-ac8e-cfa5a3eb74cf.html" target="_blank"><strong>April 18 fire</strong></a> at the Peace United Church of Christ at 1503 2<sup>nd</sup> Avenue NE was caused by arson.  The Rochester Fire Department (RFD) says the church sustained over $2.5 million in damage. </p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>RPD and RFD are now asking anyone with information about the arson to please come forward.  Tips can be shared anonymously through Crime Stoppers at 1-800-222-TIPS or the Arson Hotline at 1-800-723-2020.  Information leading to the identification of the person(s) responsible is eligible for a reward.  </p><p>Information can also be sent to Investigator Todd Schwanke at 507-328-2894 or <a href="mailto:tschwanke@rochestermn.gov">tschwanke@rochestermn.gov</a>.&nbsp;</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below">
                                    <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Public%20asked%20to%20help%20solve%20Rochester%20church%20arson&via=KIMTNews3&url=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.kimt.com/tncms/asset/editorial/d42c8e50-cff3-11ec-b72f-8b5d626a1300" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BAllen%20Media%20Broadcasting%5D%20Public%20asked%20to%20help%20solve%20Rochester%20church%20arson&body=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"d42c8e50-cff3-11ec-b72f-8b5d626a1300"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-d42c8e50-cff3-11ec-b72f-8b5d626a1300-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="d42c8e50-cff3-11ec-b72f-8b5d626a1300" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="d42c8e50-cff3-11ec-b72f-8b5d626a1300" class="save-list-d42c8e50-cff3-11ec-b72f-8b5d626a1300-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="d42c8e50-cff3-11ec-b72f-8b5d626a1300" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                                </div>
                            

                            </div>
                        
                    </div>
                </div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    
                    <div class="asset-tags">
                        <h4>Tags</h4>
                        <ul class="list-inline"><li>
                    <a href="/search/?k=%22rochester%22#tncms-source=keyword" class="tag-rochester label label-default" data-tncms-track-dmp='search: rochester' rel="nofollow">Rochester</a>
                </li> <li>
                    <a href="/search/?k=%22church%22#tncms-source=keyword" class="tag-church label label-default" data-tncms-track-dmp='search: church' rel="nofollow">Church</a>
                </li> <li>
                    <a href="/search/?k=%22fire%22#tncms-source=keyword" class="tag-fire label label-default" data-tncms-track-dmp='search: fire' rel="nofollow">Fire</a>
                </li> <li>
                    <a href="/search/?k=%22arson%22#tncms-source=keyword" class="tag-arson label label-default" data-tncms-track-dmp='search: arson' rel="nofollow">Arson</a>
                </li> <li>
                    <a href="/search/?k=%22peace%20united%22#tncms-source=keyword" class="tag-peace-united label label-default" data-tncms-track-dmp='search: peace-united' rel="nofollow">Peace United</a>
                </li> <li>
                    <a href="/search/?k=%22tips%22#tncms-source=keyword" class="tag-tips label label-default" data-tncms-track-dmp='search: tips' rel="nofollow">Tips</a>
                </li> <li>
                    <a href="/search/?k=%22police%22#tncms-source=keyword" class="tag-police label label-default" data-tncms-track-dmp='search: police' rel="nofollow">Police</a>
                </li> <li>
                    <a href="/search/?k=%22information%22#tncms-source=keyword" class="tag-information label label-default" data-tncms-track-dmp='search: information' rel="nofollow">Information</a>
                </li> </ul>
                    </div>
                    

                    

                    

                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-fe1dfbca-52cd-11ec-819f-bf296f1d62ea">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.kimt.com/users/profile/Mike%20Bunge" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        <img alt="Mike Bunge" src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/avatars/f/e1/dfb/fe1dfbca-52cd-11ec-819f-bf296f1d62ea.f7bcef65eaa8b907ca68bc3f524912bd.png?_dc=1638380544" width="200" height="200" loading="lazy" class="img-responsive lazyload tnt-user-avatar" />
                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.kimt.com/users/profile/Mike%20Bunge" rel="author" class="tnt-user-profile-link tnt-user-name">Mike Bunge</a>
                                </h4><p class="tnt-user-title small text-muted">Assignment Editor</p>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:mbunge@kimt.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul><div class="followed-notify-link hidden-print"><button id="follow-author-fe1dfbca-52cd-11ec-819f-bf296f1d62ea" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=fe1dfbca-52cd-11ec-819f-bf296f1d62ea&amp;s=start_time&amp;sd=desc" data-subject="Mike Bunge" data-description="Whenever Mike Bunge posts new content, you'll get an email delivered to your inbox with a link." data-name="Mike Bunge notification" data-author-id="fe1dfbca-52cd-11ec-819f-bf296f1d62ea" data-user-url="https://www.kimt.com/users/">
        <i class="fas tnt-star"></i> Follow Mike Bunge
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" data-tncms-track-dmp='is_followed_notifications_user'>
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.kimt.com/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.kimt.com/users/login/?referer_url=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://www.kimt.com/users/signup/?referer_url=https%3A%2F%2Fwww.kimt.com%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1282897" class="tncms-block">
        <div id="rc-widget-0a7170" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="174830"></div>
<script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer></script>
    </div></div>

                    <div class="asset-comments hidden-print">
            <div id="comments-container" class="comments-container openweb-comments" data-url="https://www.kimt.com/tncms/openweb/sso/user/register/">
                    <div id="comments" class="subscriber-hide"></div>
                    
                    <!-- START: OpenWeb Embed -->
                    <script 
                        async 
                        src="https://launcher.spot.im/spot/sp_c8670lg9"
                        data-spotim-module="spotim-launcher"
                        data-post-url="https://www.kimt.com/news/public-asked-to-help-solve-rochester-church-arson/article_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"
                        data-article-tags="News"    
                        data-post-id="d42c8e50-cff3-11ec-b72f-8b5d626a1300">
                    </script>
                    <!-- END: OpenWeb Embed -->
            </div>
            
        </div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"><div id="tncms-block-1142280" class="tncms-block small-headline"><section id="block-1142280" class="block emphasis-h3    tnt-no-margin-bottom" ><div class="clearfix">
    
    <div class="block-title title-1142280 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/news/">
                
                More From KIMT News 3
                
                    </a>
                
            </h3>
        </div>
    </div></div><div class="card-grid   card-img-md">
        
        
            <div class=" row">
        
        <div class=" col-sm-2 ">
                 
                                
                    <article id="card-summary-1142280-c21e0a00-8a29-11ec-8f83-53b8d50d7bd5" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-blur  tnt-section-news">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-c21e0a00-8a29-11ec-8f83-53b8d50d7bd5 media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/retailers-partnering-to-distribute-free-n95-masks/article_c21e0a00-8a29-11ec-8f83-53b8d50d7bd5.html" class="tnt-asset-link"  aria-label="Retailers partnering to distribute free N95 masks">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Retailers partnering to distribute free N95 masks"
                            class="img-responsive lazyload full blur"
                            width="1280"
                            height="720"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=150%2C84 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=200%2C113 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=225%2C127 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=300%2C169 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=400%2C225 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=540%2C304 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=640%2C360 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=750%2C422 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=990%2C557 990w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=1035%2C582 1035w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=1200%2C675 1200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=1280%2C720 1333w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/2/59/25937b41-1339-5460-a81d-e774d66f2dd9/62044e8b2c0e6.image.jpg?resize=200%2C113" alt="" aria-hidden="true" loading="lazy" height="113" width="200"/>
         </div>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/news" class="tnt-section-tag">News</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/retailers-partnering-to-distribute-free-n95-masks/article_c21e0a00-8a29-11ec-8f83-53b8d50d7bd5.html" class="tnt-asset-link" aria-label="Retailers partnering to distribute free N95 masks">
        

        
            Retailers partnering to distribute free N95 masks</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-09T22:27:00-06:00" class="tnt-date asset-date text-muted">Feb 9, 2022</time></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-2 ">
                 
                                
                    <article id="card-summary-1142280-f5e53d7e-e9bf-5ac0-9304-fb2f676d7d01" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-blur  tnt-section-news tnt-sub-section-local">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-f5e53d7e-e9bf-5ac0-9304-fb2f676d7d01 media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/sheriff-mayo-1-spots-vehicle-in-cornfield-deceased-person-later-found-inside/article_f5e53d7e-e9bf-5ac0-9304-fb2f676d7d01.html" class="tnt-asset-link"  aria-label="Sheriff: Mayo 1 spots vehicle in cornfield, deceased person later found inside">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Sheriff: Mayo 1 spots vehicle in cornfield, deceased person later found inside"
                            class="img-responsive lazyload full blur"
                            width="800"
                            height="450"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/8/12/81220ddf-2f63-5ff1-8702-2f0edb196d86/619d25b131652.image.jpg?resize=150%2C84 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/8/12/81220ddf-2f63-5ff1-8702-2f0edb196d86/619d25b131652.image.jpg?resize=200%2C113 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/8/12/81220ddf-2f63-5ff1-8702-2f0edb196d86/619d25b131652.image.jpg?resize=225%2C127 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/8/12/81220ddf-2f63-5ff1-8702-2f0edb196d86/619d25b131652.image.jpg?resize=300%2C169 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/8/12/81220ddf-2f63-5ff1-8702-2f0edb196d86/619d25b131652.image.jpg?resize=400%2C225 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/8/12/81220ddf-2f63-5ff1-8702-2f0edb196d86/619d25b131652.image.jpg?resize=540%2C304 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/8/12/81220ddf-2f63-5ff1-8702-2f0edb196d86/619d25b131652.image.jpg?resize=640%2C360 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/8/12/81220ddf-2f63-5ff1-8702-2f0edb196d86/619d25b131652.image.jpg?resize=750%2C422 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/8/12/81220ddf-2f63-5ff1-8702-2f0edb196d86/619d25b131652.image.jpg?resize=800%2C450 990w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/8/12/81220ddf-2f63-5ff1-8702-2f0edb196d86/619d25b131652.image.jpg?resize=200%2C113" alt="" aria-hidden="true" loading="lazy" height="113" width="200"/>
         </div>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/news/local" class="tnt-section-tag">Local</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/local/sheriff-mayo-1-spots-vehicle-in-cornfield-deceased-person-later-found-inside/article_f5e53d7e-e9bf-5ac0-9304-fb2f676d7d01.html" class="tnt-asset-link" aria-label="Sheriff: Mayo 1 spots vehicle in cornfield, deceased person later found inside">
        

        
            Sheriff: Mayo 1 spots vehicle in cornfield, deceased person later found inside</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date"><span class="text-muted tnt-update-old">Updated </span>
        <time datetime="2021-12-02T09:48:55-06:00" class="tnt-date tnt-update-old asset-date text-muted">Dec 2, 2021</time>
    </li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-2 ">
                 
                                
                    <article id="card-summary-1142280-5510513e-7e2b-11ec-8b74-ff18e7ab328c" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-blur  tnt-section-news">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-5510513e-7e2b-11ec-8b74-ff18e7ab328c media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/rochester-man-pleads-guilty-to-summer-crime-not-guilty-to-winter-crimes/article_5510513e-7e2b-11ec-8b74-ff18e7ab328c.html" class="tnt-asset-link"  aria-label="Rochester man pleads guilty to summer crime, not guilty to winter crimes">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Rochester man pleads guilty to summer crime, not guilty to winter crimes"
                            class="img-responsive lazyload full blur"
                            width="1920"
                            height="1080"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=150%2C84 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=200%2C113 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=225%2C127 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=300%2C169 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=400%2C225 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=540%2C304 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=640%2C360 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=750%2C422 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=990%2C557 990w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=1035%2C582 1035w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=1200%2C675 1200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=1333%2C750 1333w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=1476%2C830 1476w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=1920%2C1080 2008w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/a/8e/a8e1319a-6272-11ec-a9d2-bf2f4a55b794/61c1f2b66f266.image.jpg?resize=200%2C113" alt="" aria-hidden="true" loading="lazy" height="113" width="200"/>
         </div>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/news" class="tnt-section-tag">News</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/rochester-man-pleads-guilty-to-summer-crime-not-guilty-to-winter-crimes/article_5510513e-7e2b-11ec-8b74-ff18e7ab328c.html" class="tnt-asset-link" aria-label="Rochester man pleads guilty to summer crime, not guilty to winter crimes">
        

        
            Rochester man pleads guilty to summer crime, not guilty to winter crimes</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-01-25T16:08:00-06:00" class="tnt-date asset-date text-muted">Jan 25, 2022</time></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-2 ">
                 
                                
                    <article id="card-summary-1142280-964ab89d-2cb5-5624-89f4-776419a275ce" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-blur  tnt-section-news tnt-sub-section-iowa">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-964ab89d-2cb5-5624-89f4-776419a275ce media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/iowa/police-say-remains-of-missing-woman-found-near-des-moines-river/article_964ab89d-2cb5-5624-89f4-776419a275ce.html" class="tnt-asset-link"  aria-label="Police say remains of missing woman found near Des Moines River">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Police say remains of missing woman found near Des Moines River"
                            class="img-responsive lazyload full blur"
                            width="800"
                            height="450"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/d/20/d20be8de-4d4c-5495-bede-134780da146d/619d278d849fb.image.jpg?resize=150%2C84 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/d/20/d20be8de-4d4c-5495-bede-134780da146d/619d278d849fb.image.jpg?resize=200%2C113 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/d/20/d20be8de-4d4c-5495-bede-134780da146d/619d278d849fb.image.jpg?resize=225%2C127 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/d/20/d20be8de-4d4c-5495-bede-134780da146d/619d278d849fb.image.jpg?resize=300%2C169 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/d/20/d20be8de-4d4c-5495-bede-134780da146d/619d278d849fb.image.jpg?resize=400%2C225 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/d/20/d20be8de-4d4c-5495-bede-134780da146d/619d278d849fb.image.jpg?resize=540%2C304 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/d/20/d20be8de-4d4c-5495-bede-134780da146d/619d278d849fb.image.jpg?resize=640%2C360 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/d/20/d20be8de-4d4c-5495-bede-134780da146d/619d278d849fb.image.jpg?resize=750%2C422 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/d/20/d20be8de-4d4c-5495-bede-134780da146d/619d278d849fb.image.jpg?resize=800%2C450 990w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/d/20/d20be8de-4d4c-5495-bede-134780da146d/619d278d849fb.image.jpg?resize=200%2C113" alt="" aria-hidden="true" loading="lazy" height="113" width="200"/>
         </div>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/news/iowa" class="tnt-section-tag">Iowa</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/iowa/police-say-remains-of-missing-woman-found-near-des-moines-river/article_964ab89d-2cb5-5624-89f4-776419a275ce.html" class="tnt-asset-link" aria-label="Police say remains of missing woman found near Des Moines River">
        

        
            Police say remains of missing woman found near Des Moines River</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date"><span class="text-muted tnt-update-old">Updated </span>
        <time datetime="2021-12-09T13:11:14-06:00" class="tnt-date tnt-update-old asset-date text-muted">Dec 9, 2021</time>
    </li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-2 ">
                 
                                
                    <article id="card-summary-1142280-c47f338b-82a1-5612-9018-9c179a24c268" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-blur  tnt-section-archive">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-c47f338b-82a1-5612-9018-9c179a24c268 media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/archive/democrats-push-to-retool-health-care-programs-for-millions/article_c47f338b-82a1-5612-9018-9c179a24c268.html" class="tnt-asset-link"  aria-label="Democrats push to retool health care programs for millions">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Democrats push to retool health care programs for millions"
                            class="img-responsive lazyload ap-photo full blur"
                            width="800"
                            height="450"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/3/31/331b7a2b-7f27-54aa-bd32-871706928350/619d225c5e600.image.jpg?resize=150%2C84 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/3/31/331b7a2b-7f27-54aa-bd32-871706928350/619d225c5e600.image.jpg?resize=200%2C113 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/3/31/331b7a2b-7f27-54aa-bd32-871706928350/619d225c5e600.image.jpg?resize=225%2C127 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/3/31/331b7a2b-7f27-54aa-bd32-871706928350/619d225c5e600.image.jpg?resize=300%2C169 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/3/31/331b7a2b-7f27-54aa-bd32-871706928350/619d225c5e600.image.jpg?resize=400%2C225 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/3/31/331b7a2b-7f27-54aa-bd32-871706928350/619d225c5e600.image.jpg?resize=540%2C304 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/3/31/331b7a2b-7f27-54aa-bd32-871706928350/619d225c5e600.image.jpg?resize=640%2C360 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/3/31/331b7a2b-7f27-54aa-bd32-871706928350/619d225c5e600.image.jpg?resize=750%2C422 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/3/31/331b7a2b-7f27-54aa-bd32-871706928350/619d225c5e600.image.jpg?resize=800%2C450 990w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/3/31/331b7a2b-7f27-54aa-bd32-871706928350/619d225c5e600.image.jpg?resize=200%2C113" alt="" aria-hidden="true" loading="lazy" height="113" width="200"/>
         </div>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/archive" class="tnt-section-tag">Archive</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/archive/democrats-push-to-retool-health-care-programs-for-millions/article_c47f338b-82a1-5612-9018-9c179a24c268.html" class="tnt-asset-link" aria-label="Democrats push to retool health care programs for millions">
        

        
            Democrats push to retool health care programs for millions</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date"><span class="text-muted tnt-update-old">Updated </span>
        <time datetime="2021-12-02T09:44:20-06:00" class="tnt-date tnt-update-old asset-date text-muted">Dec 2, 2021</time>
    </li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-2 last-grid-item">
                 
                                
                    <article id="card-summary-1142280-a1e6171f-9b46-5dd3-b973-4a37927a90ce" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-blur  tnt-section-news tnt-sub-section-cerro-gordo-county">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-a1e6171f-9b46-5dd3-b973-4a37927a90ce media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/cerro-gordo-county/stormteam-3-drier-and-warmer-conditions-expected-for-the-weekend/article_a1e6171f-9b46-5dd3-b973-4a37927a90ce.html" class="tnt-asset-link"  aria-label="StormTeam 3: Drier and Warmer Conditions Expected for the Weekend">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="StormTeam 3: Drier and Warmer Conditions Expected for the Weekend"
                            class="img-responsive lazyload full blur"
                            width="800"
                            height="450"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/a3/5a3ef92e-f58c-5459-8b50-7ef9b78d4175/619d29bda8171.image.jpg?resize=150%2C84 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/a3/5a3ef92e-f58c-5459-8b50-7ef9b78d4175/619d29bda8171.image.jpg?resize=200%2C113 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/a3/5a3ef92e-f58c-5459-8b50-7ef9b78d4175/619d29bda8171.image.jpg?resize=225%2C127 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/a3/5a3ef92e-f58c-5459-8b50-7ef9b78d4175/619d29bda8171.image.jpg?resize=300%2C169 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/a3/5a3ef92e-f58c-5459-8b50-7ef9b78d4175/619d29bda8171.image.jpg?resize=400%2C225 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/a3/5a3ef92e-f58c-5459-8b50-7ef9b78d4175/619d29bda8171.image.jpg?resize=540%2C304 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/a3/5a3ef92e-f58c-5459-8b50-7ef9b78d4175/619d29bda8171.image.jpg?resize=640%2C360 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/a3/5a3ef92e-f58c-5459-8b50-7ef9b78d4175/619d29bda8171.image.jpg?resize=750%2C422 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/a3/5a3ef92e-f58c-5459-8b50-7ef9b78d4175/619d29bda8171.image.jpg?resize=800%2C450 990w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/assets/v3/editorial/5/a3/5a3ef92e-f58c-5459-8b50-7ef9b78d4175/619d29bda8171.image.jpg?resize=200%2C113" alt="" aria-hidden="true" loading="lazy" height="113" width="200"/>
         </div>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/news/cerro-gordo-county" class="tnt-section-tag">Cerro Gordo County</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/cerro-gordo-county/stormteam-3-drier-and-warmer-conditions-expected-for-the-weekend/article_a1e6171f-9b46-5dd3-b973-4a37927a90ce.html" class="tnt-asset-link" aria-label="StormTeam 3: Drier and Warmer Conditions Expected for the Weekend">
        

        
            StormTeam 3: Drier and Warmer Conditions Expected for the Weekend</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date"><span class="text-muted tnt-update-old">Updated </span>
        <time datetime="2021-12-02T09:56:36-06:00" class="tnt-date tnt-update-old asset-date text-muted">Dec 2, 2021</time>
    </li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
                
                    <div class="clearfix hidden-xs"></div>
                
            
            
        
        <div class="clearfix hidden-xs"></div>
        
        
        </div>
        </div></section></div><div id="tncms-block-1282900" class="tncms-block">
        <script id="4077221a11ee4bfeb71fca5a692c7b2a">(new Image()).src = 'https://capi.connatix.com/tr/si?token=3e467e52-ebce-4794-a0de-233fe9f74067'; cnxps.cmd.push(function () { cnxps({ playerId: "3e467e52-ebce-4794-a0de-233fe9f74067" }).render("4077221a11ee4bfeb71fca5a692c7b2a"); });</script>
    </div><div id="tncms-block-1142901" class="tncms-block"><section id="block-1142901" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1142901 ">
        <div class="block-title-inner">
            <h3>
                
                Recommended for you
                
            </h3>
        </div>
    </div></div><div id="card-grid-behavioral-1142901" class="card-grid-behavioral card-grid card-img- card-compact"  data-lotame-track="true"><div class=" row equal equal-wrap"><div id="tncms-recommendations-1142901" class="recommendations-container"></div>
            <div class="clearfix hidden-xs"></div>
            </div>
        </div></section></div></div></div>
            </div>
        </div>
    </div>
    
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "><div id="tncms-block-1142802" class="tncms-block small-button"><section id="block-1142802" class="block emphasis-h3   " ><div class="block"><a href="https://itunes.apple.com/us/app/kimt-news-3/id1217561442?mt=8" rel="nofollow noopener" target="_blank" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51aad6ee-38cc-11ec-bb08-57a404b5b0d5.png?resize=150%2C45 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51aad6ee-38cc-11ec-bb08-57a404b5b0d5.png?resize=200%2C60 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51aad6ee-38cc-11ec-bb08-57a404b5b0d5.png?resize=225%2C68 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51aad6ee-38cc-11ec-bb08-57a404b5b0d5.png?resize=300%2C90 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51aad6ee-38cc-11ec-bb08-57a404b5b0d5.png?resize=400%2C120 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51aad6ee-38cc-11ec-bb08-57a404b5b0d5.png?resize=540%2C162 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51aad6ee-38cc-11ec-bb08-57a404b5b0d5.png?resize=640%2C192 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51aad6ee-38cc-11ec-bb08-57a404b5b0d5.png?resize=750%2C226 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51aad6ee-38cc-11ec-bb08-57a404b5b0d5.png?resize=990%2C298 990w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51aad6ee-38cc-11ec-bb08-57a404b5b0d5.png?resize=1035%2C311 1035w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51aad6ee-38cc-11ec-bb08-57a404b5b0d5.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="1084"
                height="326"
                alt=""
                aria-hidden="true"></a></div></section></div><div id="tncms-block-1142805" class="tncms-block small-button"><section id="block-1142805" class="block emphasis-h3   " ><div class="block"><a href="https://play.google.com/store/apps/details?id=com.heartland.kimt&hl=en" rel="nofollow noopener" target="_blank" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51ac44ac-38cc-11ec-bb09-db58e4c92d66.png?resize=150%2C45 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51ac44ac-38cc-11ec-bb09-db58e4c92d66.png?resize=200%2C60 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51ac44ac-38cc-11ec-bb09-db58e4c92d66.png?resize=225%2C68 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51ac44ac-38cc-11ec-bb09-db58e4c92d66.png?resize=300%2C90 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51ac44ac-38cc-11ec-bb09-db58e4c92d66.png?resize=400%2C120 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51ac44ac-38cc-11ec-bb09-db58e4c92d66.png?resize=540%2C162 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51ac44ac-38cc-11ec-bb09-db58e4c92d66.png?resize=640%2C192 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51ac44ac-38cc-11ec-bb09-db58e4c92d66.png?resize=750%2C226 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51ac44ac-38cc-11ec-bb09-db58e4c92d66.png?resize=990%2C298 990w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51ac44ac-38cc-11ec-bb09-db58e4c92d66.png?resize=1035%2C311 1035w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/51ac44ac-38cc-11ec-bb09-db58e4c92d66.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="1084"
                height="326"
                alt=""
                aria-hidden="true"></a></div></section></div><div id="tncms-block-1142808" class="tncms-block bigger-button"><section id="block-1142808" class="block emphasis-h3   " ><div id="promo-button-1142808" class="promo-button"><a href="/contact/email"><button type="button" class="btn btn-block btn-lg">Subscribe Now!</button></a></div></section></div></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1142235" class="tncms-block padding-bottom footer-logo"><div id="site-logo-1142235" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=200%2C75" 
            srcset="https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=150%2C56 150w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=200%2C75 200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=225%2C85 225w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=300%2C113 300w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=400%2C151 400w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=540%2C203 540w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=640%2C241 640w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=750%2C282 750w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=990%2C373 990w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=1035%2C389 1035w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=1200%2C452 1200w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=1333%2C502 1333w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png?resize=1476%2C555 1476w, https://bloximages.newyork1.vip.townnews.com/kimt.com/content/tncms/custom/image/40ca3f66-89b4-11ec-82cf-8b9e0b009d00.png 2008w"
            sizes="(min-width: 1396px) 455px, calc(33.33vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="1900"
            height="715"
            alt="site-logo"
            ></a>
        </div></div></div><div id="tncms-block-1142238" class="tncms-block social-links padding-top padding-bottom"><div class="follow-links-1142238 default">
    
    <section id="block-1142238" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/KIMTNews3" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/KIMTNews3" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.kimt.com",
  "sameAs" : ["https://www.facebook.com/KIMTNews3","https://twitter.com/KIMTNews3"]
}
</script>
<div class="clearfix"></div></div></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1142244" class="tncms-block"><section id="block-1142244" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1142244 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link    tnt-section-news"  href="/news/"  tabindex="0" >
                    <span class="nav-label ">News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-weather"  href="/weather/"  tabindex="0" >
                    <span class="nav-label ">Weather</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sports"  href="/sports/"  tabindex="0" >
                    <span class="nav-label ">Sports</span>
                </a></li><li>
                <a class="nav-link    tnt-section-video"  href="/video/"  tabindex="0" >
                    <span class="nav-label ">Video</span>
                </a></li><li>
                <a class="nav-link    tnt-section-community"  href="/community/"  tabindex="0" >
                    <span class="nav-label ">Community</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact"  href="/contact/"  tabindex="0" >
                    <span class="nav-label ">Contact</span>
                </a></li><li>
                <a class="nav-link    tnt-section-deals"  href="https://deals.allenmediabroadcasting.com/kimt.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Deals</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1142241" class="tncms-block"><section id="block-1142241" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1142241 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link    tnt-section-search"  href="/search/"  tabindex="0" >
                    <span class="nav-label ">Search</span>
                </a></li><li>
                <a class="nav-link    tnt-section-careers"  href="https://allenmediabroadcasting.com/careers/kimt.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Careers</span>
                </a></li><li>
                <a class="nav-link    tnt-section-advertise-with-kimt"  href="/contact/advertise/"  tabindex="0" >
                    <span class="nav-label ">Advertise with KIMT</span>
                </a></li><li>
                <a class="nav-link    tnt-section-fcc-public-inspection-file"  href="https://publicfiles.fcc.gov/tv-profile/KIMT/programs-list/"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">FCC Public Inspection File</span>
                </a></li><li>
                <a class="nav-link    tnt-section-eeo-report"  href="/kimt-eeo-report-2021/pdf_629e0652-41a9-11ec-aedf-6bde285e5f9a.html"  tabindex="0" >
                    <span class="nav-label ">EEO Report</span>
                </a></li><li>
                <a class="nav-link    tnt-section-closed-captioning"  href="/contact/closed-captioning/"  tabindex="0" >
                    <span class="nav-label ">Closed Captioning</span>
                </a></li><li>
                <a class="nav-link    tnt-section-child-programming"  href="https://publicfiles.fcc.gov/tv-profile/KIMT/programs-list/"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Child Programming</span>
                </a></li><li>
                <a class="nav-link    tnt-section-fcc-applications"  href="https://publicfiles.fcc.gov/tv-profile/KIMT/applications-and-related-materials/"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">FCC Applications</span>
                </a></li><li>
                <a class="nav-link    tnt-section-advertiser-payments"  href="https://www.kimt.com/contact/advertise/kimt-advertiser-payments/html_c0a64408-5dab-11ec-9aa7-ff5ac11b4822.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Advertiser Payments</span>
                </a></li></ul></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1142247" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1142247"><div class="col-md-7"><small>&copy; Copyright 2022 <a href="/">Allen Media Broadcasting</a>, 112 N. Pennsylvania Ave., Mason City, IA</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("d42c8e50-cff3-11ec-b72f-8b5d626a1300")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc16305.add('act', dmpData);_cc16305.bcp();
            });
        });
    
    </script>
    
     
<script>
let newObserver = new IntersectionObserver(function(entries) {
   if(entries[0].intersectionRatio === 0)
      document.querySelector("#site-navbar-container").classList.add("sticky-navbar");
   else if(entries[0].intersectionRatio === 1)
      document.querySelector("#site-navbar-container").classList.remove("sticky-navbar");
}, { threshold: [0,1] });
newObserver.observe(document.querySelector("#site-header-container"));
</script>

<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["news", "news/crime", "news/local", "news/olmsted-county", "news/top-stories"],
            'tncms.asset.flags': [""],
            'tncms.asset.keywords': ["rochester", "church", "fire", "arson", "peace united", "tips", "police", "information"]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-1142349'),
            query_input = d.getElementById('site-search-1142349-term'),
            search_dropdown = d.getElementById('site-search-1142349-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-1142349 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.fa820af8c4b7651b60faff4dca7ed722.js"></script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-1142328'),
            query_input = d.getElementById('site-search-1142328-term'),
            search_dropdown = d.getElementById('site-search-1142328-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-1142328 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ document.addEventListener("spot-im-login-start", function(event) {window.location.href = "/users/signup/?referer_url=%2Fnews%2Fpublic-asked-to-help-solve-rochester-church-arson%2Farticle_d42c8e50-cff3-11ec-b72f-8b5d626a1300.html"}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/withinviewport.1f94ee79a22e6ee8e9c0bb61dec9999b.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.withinviewport.6ef0fee1774e9b313c264a5736522e35.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/kimt.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.scrollstop.934c2bd4d6bebe0494bcb9dd4b1b6ca1.js"></script>
<script>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</script>
<script>/*<![CDATA[*/ 
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc16305.add('act', dmpData);_cc16305.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>