 





 
<!DOCTYPE html>
<html lang="en">
	<head>

		
				
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta charset="utf-8">
		<meta name="google-site-verification" content="" />
		<meta name="msvalidate.01" content="" />
		<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
		
													<link rel="amphtml" href="http://www.kimt.com/templates/AMP?contentID=573400091">
				<link rel="canonical" href="https://www.kimt.com/content/news/Minnesota-could-free-man-serving-life-in-childs-2002-death-573400091.html">
										
												                                        		
										
			
			<title>Minnesota could free man serving life in child's 2002 death</title>

			<meta name="description" content="Minnesota’s pardon board will consider freeing a Black man who was imprisoned for life as a teenager in the 2002 death of a girl who was hit by a stray bullet while doing homework at her dining room table. ">
			<meta property="og:url" content="https://www.kimt.com/content/news/Minnesota-could-free-man-serving-life-in-childs-2002-death-573400091.html" />
			<meta property="og:type" content="article" />
			<meta property="og:title" content="Minnesota could free man serving life in child's 2002 death" />
			<meta property="og:description" content="Minnesota’s pardon board will consider freeing a Black man who was imprisoned for life as a teenager in the 2002 death of a girl who was hit by a stray bullet while doing homework at her dining room table. " />
			<meta property="og:image" content="https://media.heartlandtv.com/images/Minnesota+news+3.jpg" />
			<meta property="og:site_name" content="KIMT News" />
			<meta property="fb:app_id" content="2071402786444827" />
	
			<meta name="twitter:card" content="summary_large_image">
			<meta name="twitter:site" content="@publisher_handle">
			<meta name="twitter:title" content="Minnesota could free man serving life in child's 2002 death">
			<meta name="twitter:description" content="Minnesota’s pardon board will consider freeing a Black man who was imprisoned for life as a teenager in the 2002 death of a girl who was hit by a stray bullet while doing homework at her dining room table. ">
			<meta name="twitter:image" content="https://media.heartlandtv.com/images/Minnesota+news+3.jpg" />		
				
		
		
		<link rel="icon" type="image/png" href="https://media.heartlandtv.com/designimages/FAV-ICON.png">
	 
		<link rel="stylesheet" media="screen" href="https://s3.us-east-2.amazonaws.com/heartland-css/vendor.min.css">
		<link id="mainStyles" rel="stylesheet" media="screen" href="https://www.kimt.com/includes/styles.min.css">		
		<link rel="StyleSheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css">
		<link id="heartlandStyles" rel="stylesheet" media="screen" href="https://s3.us-east-2.amazonaws.com/heartland-css/heartland.css">
		<link id="gridStyles" rel="stylesheet" media="screen" href="https://s3.us-east-2.amazonaws.com/heartland-css/bootstrap-grid.css">
		<link id="appBanner" rel="stylesheet" media="screen" href="https://www.kimt.com/includes/smart-app-banner.css">	
		
		<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.2.1/jquery.min.js"></script>
		<script src="https://www.kimt.com/includes/modernizr.min.js"></script>
                 			<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script> 
		
				    <meta name="apple-itunes-app" content="app-id=1217561442">
		    <link rel="apple-touch-icon" href="https://media.heartlandtv.com/designimages/kikmt.png" />
		    				
		    		    <meta name="google-play-app" content="app-id=com.heartland.kimt">
		    <link rel="android-touch-icon" href="https://media.heartlandtv.com/designimages/kikmt.png" />
		    		

					<style>/* latin-ext */
@font-face {
  font-family: 'Libre Franklin';
  font-style: normal;
  font-weight: 400;
  src: local('Libre Franklin'), local('LibreFranklin-Regular'), url(https://fonts.gstatic.com/s/librefranklin/v2/jizDREVItHgc8qDIbSTKq4XkRiUR2zcLig.woff2) format('woff2');
  unicode-range: U+0100-024F, U+0259, U+1E00-1EFF, U+2020, U+20A0-20AB, U+20AD-20CF, U+2113, U+2C60-2C7F, U+A720-A7FF;
}
/* latin */
@font-face {
  font-family: 'Libre Franklin';
  font-style: normal;
  font-weight: 400;
  src: local('Libre Franklin'), local('LibreFranklin-Regular'), url(https://fonts.gstatic.com/s/librefranklin/v2/jizDREVItHgc8qDIbSTKq4XkRiUf2zc.woff2) format('woff2');
  unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}

body {font-family:"Libre Franklin", "Arial", sans-serif}</style>
				
		<!-- Global site tag (gtag.js) - Google Analytics -->
		<script async src="https://www.googletagmanager.com/gtag/js?id=UA-54612925-18"></script>
		<script>
		  window.dataLayer = window.dataLayer || [];
		  function gtag(){dataLayer.push(arguments);}
		  gtag('js', new Date());
		
		  gtag('config', 'UA-54612925-14');
		</script>
		
		
		<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
		<script>
		  var googletag = googletag || {};
		  googletag.cmd = googletag.cmd || [];
		</script>
		<script>
		function resizeText(multiplier) {
  		if (document.getElementById("article").style.fontSize == "") {
   		 document.getElementById("article").style.fontSize = "1.0em";
  			}
  			document.getElementById("article").style.fontSize = parseFloat(document.getElementById("article").style.fontSize) + (multiplier * 0.2) + "em";
			}
		</script>
						<script src="https://www.kimt.com/includes/smart-app-banner.js"></script>	
								<style>
		.hl-submenu {min-height:900px}
		</style>
		<style>
			.cycle-slideshow {visibility:hidden;}
			.cycle-slideshow .wxRotate:first-child {display:block;position:relative; height:auto;visibility:visible;}
			.cycle-slideshow .alertsTop:first-child {color:#fffff4;display:block;position:relative; height:0px;visibility:visible;}
		</style>
		
				<script type="text/javascript" src="//d3gpkdwom7cn1q.cloudfront.net/script.js"></script>

		
<script>
!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>


	</head>
	
	<body>


		<div id="fb-root"></div>
		<script>(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.11&appId=2071402786444827';
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));
		</script>
							<script type="text/javascript">
			      new SmartBanner({
			          daysHidden: 15,   // days to hide banner after close button is clicked (defaults to 15)
			          daysReminder: 90, // days to hide banner after "VIEW" button is clicked (defaults to 90)
			          appStoreLanguage: 'us', // language code for the App Store (defaults to users browser language)
			          title: 'KIMT',
			          author: 'KIMT - Heartland Media',
			          button: 'VIEW',
			          store: {
			              ios: 'On the App Store',
			              android: 'In Google Play',
			              windows: 'In Windows store'
			          },
			          price: {
			              ios: 'FREE',
			              android: 'FREE',
			              windows: 'FREE'
			          }
			          // , theme: '' // put platform type ('ios', 'android', etc.) here to force single theme on all device
			          // , icon: '' // full path to icon image if not using website icon image
			          // , force: 'ios' // Uncomment for platform emulation
			      });
			    </script>
	    	    	    				
  		<script type="text/javascript" >var js="0.0";</script><script type="text/javascript1.0" >js="1.0";</script><script type="text/javascript1.1">js="1.1";</script><script type="text/javascript1.2" >js="1.2";</script><script type="text/javascript1.3">js="1.3";</script><script type="text/javascript1.4" >js="1.4";</script><script type="text/javascript1.5">js="1.5";</script><script type="text/javascript1.6">js="1.6";</script><script type="text/javascript1.7">js="1.7";</script><script type="text/javascript1.8">js="1.8";</script><script type="text/javascript1.9">js="1.9";</script><script type="text/javascript"> 
/* <![CDATA[ */
var bb=new Image();var _ti=910;var _q="";var na=(navigator.appName=="Netscape");var ns=(navigator.appName.substring(0,9)=="Microsoft");var _qDate=new Date();var _r=(document.referrer.indexOf(getdomain(location))>-1?"":document.referrer);_q+="&5="+parseInt(_qDate.getTimezoneOffset());_q+="&35="+parseInt(_qDate.toString().indexOf("aylight")>-1?1:0);_q+="&6=573400091";_q+="&7=3085413";_q+="&8="+encodeURIComponent(document.location);_q+="&9="+encodeURIComponent(_r);_q+="&10="+encodeURIComponent(document.title);_q+="&11="+encodeURIComponent(navigator.userAgent);_q+="&12="+encodeURIComponent((na?navigator.language:navigator.userLanguage));_q+="&13="+((navigator.javaEnabled()?'1':'0'));_q+="&14="+encodeURIComponent(js);if(document.cookie.indexOf("cc")==-1)document.cookie="cc=t;";_q+="&15="+((document.cookie.indexOf("cc")==-1)?"0":"1");_q+="&16="+encodeURIComponent((screen.width+'x'+screen.height));_q+="&17="+encodeURIComponent(((ns)?screen.colorDepth:screen.pixelDepth));_q+="&18="+encodeURIComponent(Math.random());_q+="&19="+_ti;bb.src="https://s.clickability.com/s?"+_q;
function setonclicks(a,b){var i=0;var retval=true;while(document.links[i]!=a){i++;}if(b.li[i])retval=b.li[i].oldonclick();bye(a);return retval;}
function newonld(){if(hasonload)oldonld();lnks=new Object();var sze=document.links.length;lnks.li=new Array(sze);for (var i=0; i<sze; i++){if(document.links[i].onclick){lnks.li[i]=document.links[i];lnks.li[i].oldonclick=document.links[i].onclick;}eval("document.links[i].onclick=function(){return setonclicks(this,lnks);}");}}function bye(a){if(a.href.toLowerCase().indexOf('http')!=0)return true;if(getdomain(location)==getdomain(a))return true;if(a.href.toLowerCase().indexOf('http')!=0)return true;var _qc="https://s.clickability.com/s?19=912";_qc+="&6=573400091";_qc+="&7=3085413";_qc+="&18="+encodeURIComponent(Math.random());_qc+="&100="+a.href;_qc+="&101="+encodeURIComponent(a.text);var cc=new Image();if(na){cc.src=_qc;pc(100);}else cc.src=_qc;return true;}function pc(a){d = new Date(); while (1){m =new Date(); df = m-d;if( df > a ) {break;}}}function getdomain(a){var i=a.host.indexOf(":");return (i>=0)?a.host.substring(0,i):a.host;}if(self['setupalready']){var dosetup = false;alert('There are two $imware.tracker calls on this page. Please alert Client Services');}else{var dosetup = true;var hasonload=false;}if(dosetup && ((window.screen)||((new Array()).toSource)||((new Array()).shift&&ns))&&(navigator.userAgent.indexOf('Mac')<0)){if(window.onload){oldonld=window.onload;hasonload=true;}window.onload=newonld;var setupalready = true;}/* ]]> */
</script><noscript>
<img alt="Clickability tracking pixel" width="1" height="1" src="https://s.clickability.com/s?19=990&14=0&6=573400091&7=3085413&25=0&18=0.733376343512184">
</noscript>

	        		<!-- Off-Canvas Mobile Menu-->
						<div class="offcanvas-container" id="mobile-menu">
			<nav class="offcanvas-menu">
																																																																																																																																																																																																																																			
										        <!-- NO CHILD: /content -->
					        																			
										        <!-- NO CHILD: /home -->
					        																				                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                      																	                                                                                                            																	                                                      																	                                                                                                            																	                                                                                                            																	                                                      																	                                                      																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                      																	                                                      																	                                                      																	                                                      																
																				                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                      																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                      																	                                                      																
																				                                                                                                            																	                                                                                                            																	                                                      																	                                                                                                            																	                                                      																	                                                      																	                                                      																	                                                      																	                                                                                                            																	                                                                                                            																
																				                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																
																				                                                                                                            																
																				                                                                                                            																	                                                      																	                                                                                                            																	                                                      																
																				                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                      																	                                                                                                            																	                                                                                                            																
																				                                                                                                            																	                                                                                                            																	                                                      																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                                                                            																	                                                      																
																			
										        <!-- NO CHILD: /apps-test -->
					        																			
										        <!-- NO CHILD: /contest-scrape -->
					        																			
										        <!-- NO CHILD: /livestream -->
					        																			
										        <!-- NO CHILD: /newsletter -->
					        																			
										        <!-- NO CHILD: /payments -->
					        																			
										        <!-- NO CHILD: /search -->
					        																			
										        <!-- NO CHILD: /test -->
					        													<!-- NAVTEST -->
				<!-- [/content, /home, /apps-test, /contest-scrape, /livestream, /newsletter, /payments, /search, /test] -->
				
				
								
								<ul class="menu">
																																																																																																																																																																																																																																			
																																								
																															<li><a href="/home"><span>Home</span></a></li>
																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																					
																										<li class="has-children"><span><a href="/news"><span>News</span></a><span class="sub-menu-toggle"></span></span>
																					<ul class="offcanvas-submenu">
														
								<!-- <li><a href="/news">News</a> -->
																																						<li><a href="/news/local">Local</a></li>
																																																									<li><a href="/news/iowa">Iowa</a></li>
																																																									<li><a href="/news/minnesota">Minnesota</a></li>
																																																									<li><a href="/news/national-livestream">National News Livestream</a></li>
																																																									<li><a href="/news/protests">Minnesota Protests & Riots</a></li>
																																																									<li><a href="/news/coronavirus">Coronavirus Coverage</a></li>
																																																									<li><a href="/news/state-coronavirus">Statewide Coronavirus Cases</a></li>
																																																									<li><a href="/news/election">Election 2020</a></li>
																																																									<li><a href="/news/national">National</a></li>
																																																									<li><a href="/news/storm-coverage">Storm Coverage</a></li>
																																																																										<li><a href="http://www.kimt.com/news/national/?category=Health" target="_parent">National Health News</a></li>
																																																																										<li><a href="/news/health">Health</a></li>
																																																									<li><a href="/news/heart-health">Heart Health</a></li>
																																																																																											<li><a href="/news/traffic-reports">Traffic Maps & Cams</a></li>
																																																									<li><a href="/news/movie-reviews">Movie Reviews</a></li>
																																																									<li><a href="/news/ag-news">Ag News</a></li>
																																																																																																						</ul>
						</li>
																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																				
																										<li class="has-children"><span><a href="/weather"><span>Weather</span></a><span class="sub-menu-toggle"></span></span>
																					<ul class="offcanvas-submenu">
														
								<!-- <li><a href="/weather">Weather</a> -->
																																						<li><a href="/weather/interactive-radar">Radar</a></li>
																																																									<li><a href="/weather/forecast">Forecast</a></li>
																																																									<li><a href="/weather/maps-radars">Maps & Radars</a></li>
																																																									<li><a href="/weather/closings">Closings</a></li>
																																																									<li><a href="https://www.kimt.com/news/traffic-reports/" target="${subSection.target}">Traffic</a></li>
																																																									<li><a href="/weather/submit-closings">Submit Closings</a></li>
																																																									<li><a href="/weather/weather-blog">StormTeam3 Weather Blog</a></li>
																																																																										<li><a href="/weather/eye-in-the-sky">Live Eye - Tower Cams</a></li>
																																																									<li><a href="/weather/weather-tours">StormTeam 3 Tour</a></li>
																																																									<li><a href="/weather/weather-news">US Wx News</a></li>
																																																									<li><a href="/weather/warning-emails">Warning Emails</a></li>
																																																									<li><a href="/weather/weather-safety">Weather Safety</a></li>
																																																									<li><a href="/weather/weather-app">Weather App</a></li>
																																																																				</ul>
						</li>
																																																																																																																																																																																																																																																																																																												
																										<li class="has-children"><span><a href="/sports"><span>Sports</span></a><span class="sub-menu-toggle"></span></span>
																					<ul class="offcanvas-submenu">
														
								<!-- <li><a href="/sports">Sports</a> -->
																																						<li><a href="/sports/local-sports">Local Sports</a></li>
																																																									<li><a href="/sports/student-athlete-of-the-week">Student Athlete of the Week</a></li>
																																																																										<li><a href="http://www.kimt.com/news/national/?category=Sports" target="_parent">National Sports</a></li>
																																																																																																																													<li><a href="/sports/kimt-outdoors">KIMT Outdoors</a></li>
																																																									<li><a href="/sports/prep-football">Prep Football 2020</a></li>
																																		</ul>
						</li>
																																																																																																																																																					
																										<li class="has-children"><span><a href="/videos"><span>Videos</span></a><span class="sub-menu-toggle"></span></span>
																					<ul class="offcanvas-submenu">
														
								<!-- <li><a href="/videos">Videos</a> -->
																																						<li><a href="https://www.kimt.com/videos/" target="_parent">On Demand</a></li>
																																																									<li><a href="/videos/livestream">Streaming Newscasts</a></li>
																																																									<li><a href="https://www.kimt.com/about-us/our-apps" target="_parent">TV Apps</a></li>
																																																									<li><a href="https://www.youtube.com/channel/UCgiFbHIm6SzfF_lo7d98jUg" target="_blank">YouTube</a></li>
																																		</ul>
						</li>
																																																								
																										<li class="has-children"><span><a href="/my-32"><span>My 3.2</span></a><span class="sub-menu-toggle"></span></span>
																					<ul class="offcanvas-submenu">
														
								<!-- <li><a href="/my-32">My 3.2</a> -->
																																						<li><a href="http://www.mynetworktv.com/" target="_blank">My Network TV</a></li>
																																		</ul>
						</li>
																																																																																																																																							
																										<li class="has-children"><span><a href="/on-kimt"><span>On KIMT</span></a><span class="sub-menu-toggle"></span></span>
																					<ul class="offcanvas-submenu">
														
								<!-- <li><a href="/on-kimt">On KIMT</a> -->
																																						<li><a href="/on-kimt/contests">Contests</a></li>
																																																																										<li><a href="/on-kimt/whats-on">KIMT Programming</a></li>
																																																			</ul>
						</li>
																																																																																																																																																																																																																																																																																																									
																										<li class="has-children"><span><a href="/about-us"><span>About Us</span></a><span class="sub-menu-toggle"></span></span>
																					<ul class="offcanvas-submenu">
														
								<!-- <li><a href="/about-us">About Us</a> -->
																																						<li><a href="/about-us/meet-the-news-team">Meet the News Team</a></li>
																																																									<li><a href="/about-us/management-and-sales">Management & Sales</a></li>
																																																									<li><a href="/about-us/history">History</a></li>
																																																									<li><a href="/about-us/kimt-jobs">Jobs</a></li>
																																																									<li><a href="/about-us/contact-us">Contact Us</a></li>
																																																									<li><a href="/about-us/digital-marketing">Digital Marketing</a></li>
																																																																										<li><a href="https://www.kimt.com/newsletter/" target="${subSection.target}">Newsletters</a></li>
																																																									<li><a href="/about-us/our-apps">Our Apps</a></li>
																																		</ul>
						</li>
																																																																																																																																																																																																																																																																																																																																	
																										<li class="has-children"><span><a href="/community"><span>Community</span></a><span class="sub-menu-toggle"></span></span>
																					<ul class="offcanvas-submenu">
														
								<!-- <li><a href="/community">Community</a> -->
																																						<li><a href="/community/giving-your-best-volunteer-of-the-month">Giving Your Best Volunteer of the Month</a></li>
																																																									<li><a href="/community/tools-for-schools">Tools for Schools</a></li>
																																																																										<li><a href="/community/golden-apple">Golden Apple</a></li>
																																																									<li><a href="/community/calendar">Community Calendar</a></li>
																																																									<li><a href="https://www.kimt.com/content/news/Meet-the-2019-20-KIMT-Scholastic-All-Stars-570776481.html" target="_parent">2019-20 Scholastic All-Stars</a></li>
																																																									<li><a href="/community/feeding-america">Feeding America</a></li>
																																																									<li><a href="/community/local-business">Local Business Directory</a></li>
																																																									<li><a href="/community/non-profits">Non-Profits</a></li>
																																																			</ul>
						</li>
																									
																													
																													
																													
																													
																													
																																								
																							</ul>
			</nav>
		</div>
		
		<!-- REMOVED TOP BAR -->
		<div class="topbar" style="height:0px"></div>

		<!-- Navbar-->
		
		<!-- Remove ".navbar-sticky" class to make navigation bar scrollable with the page.-->
		<header class="navbar navbar-sticky">
			<!-- Search-->
			<form class="site-search" method="get" action="/search">
				<input type="text" name="site_search" title="Site Search" aria-label="Site Search" placeholder="Type to search...">
				<div class="search-tools">
					<span class="clear-search">Clear</span>
					<span class="close-search"><i class="icon-cross"></i></span>
				</div>
			</form>
			<div class="site-branding">
				<div class="inner">
				  <!-- Off-Canvas Toggle (#mobile-menu)--><a class="offcanvas-toggle menu-toggle" href="#mobile-menu" aria-label="Menu Toggle" data-toggle="offcanvas"></a>
				  <!-- Site Logo-->
				  	<a class="site-logo" href="/">
				  		<img class="img-responsive mobile-logo" src="https://media.heartlandtv.com/designimages/HEADER-LOGO.png" alt="KIMT Logo">
				  		<img class="img-responsive desktop-logo" src="https://media.heartlandtv.com/designimages/HEADER-LOGO2.png" alt="KIMT Logo">
				  	</a>
				</div>
			</div>
			<!-- Main Navigation-->
			<nav class="site-menu">
				<ul>
																																																																																																																																																																																																																																																																					
																																	
																																								<li><a href="/home"><span>Home</span></a></li>
																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																												
																																	<li><a href="/news"><span>News</span></a>
									
								<ul class="sub-menu">
									<!-- <li><a href="/news">News</a> -->
																																							<li><a href="/news/local">Local</a></li>
																																																										<li><a href="/news/iowa">Iowa</a></li>
																																																										<li><a href="/news/minnesota">Minnesota</a></li>
																																																										<li><a href="/news/national-livestream">National News Livestream</a></li>
																																																										<li><a href="/news/protests">Minnesota Protests & Riots</a></li>
																																																										<li><a href="/news/coronavirus">Coronavirus Coverage</a></li>
																																																										<li><a href="/news/state-coronavirus">Statewide Coronavirus Cases</a></li>
																																																										<li><a href="/news/election">Election 2020</a></li>
																																																										<li><a href="/news/national">National</a></li>
																																																										<li><a href="/news/storm-coverage">Storm Coverage</a></li>
																																																																												<li><a href="http://www.kimt.com/news/national/?category=Health" target="_parent">National Health News</a></li>
																																																																												<li><a href="/news/health">Health</a></li>
																																																										<li><a href="/news/heart-health">Heart Health</a></li>
																																																																																														<li><a href="/news/traffic-reports">Traffic Maps & Cams</a></li>
																																																										<li><a href="/news/movie-reviews">Movie Reviews</a></li>
																																																										<li><a href="/news/ag-news">Ag News</a></li>
																																																																																																												</ul>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																			
																																	<li><a href="/weather"><span>Weather</span></a>
									
								<ul class="sub-menu">
									<!-- <li><a href="/weather">Weather</a> -->
																																							<li><a href="/weather/interactive-radar">Radar</a></li>
																																																										<li><a href="/weather/forecast">Forecast</a></li>
																																																										<li><a href="/weather/maps-radars">Maps & Radars</a></li>
																																																										<li><a href="/weather/closings">Closings</a></li>
																																																										<li><a href="https://www.kimt.com/news/traffic-reports/" target="${subSection.target}">Traffic</a></li>
																																																										<li><a href="/weather/submit-closings">Submit Closings</a></li>
																																																										<li><a href="/weather/weather-blog">StormTeam3 Weather Blog</a></li>
																																																																												<li><a href="/weather/eye-in-the-sky">Live Eye - Tower Cams</a></li>
																																																										<li><a href="/weather/weather-tours">StormTeam 3 Tour</a></li>
																																																										<li><a href="/weather/weather-news">US Wx News</a></li>
																																																										<li><a href="/weather/warning-emails">Warning Emails</a></li>
																																																										<li><a href="/weather/weather-safety">Weather Safety</a></li>
																																																										<li><a href="/weather/weather-app">Weather App</a></li>
																																																																								</ul>
							</li>
																																																																																																																																																																																																																																																																																																																																																											
																																	<li><a href="/sports"><span>Sports</span></a>
									
								<ul class="sub-menu">
									<!-- <li><a href="/sports">Sports</a> -->
																																							<li><a href="/sports/local-sports">Local Sports</a></li>
																																																										<li><a href="/sports/student-athlete-of-the-week">Student Athlete of the Week</a></li>
																																																																												<li><a href="http://www.kimt.com/news/national/?category=Sports" target="_parent">National Sports</a></li>
																																																																																																																																		<li><a href="/sports/kimt-outdoors">KIMT Outdoors</a></li>
																																																										<li><a href="/sports/prep-football">Prep Football 2020</a></li>
																																				</ul>
							</li>
																																																																																																																																																																											
																																	<li><a href="/videos"><span>Videos</span></a>
									
								<ul class="sub-menu">
									<!-- <li><a href="/videos">Videos</a> -->
																																							<li><a href="https://www.kimt.com/videos/" target="_parent">On Demand</a></li>
																																																										<li><a href="/videos/livestream">Streaming Newscasts</a></li>
																																																										<li><a href="https://www.kimt.com/about-us/our-apps" target="_parent">TV Apps</a></li>
																																																										<li><a href="https://www.youtube.com/channel/UCgiFbHIm6SzfF_lo7d98jUg" target="_blank">YouTube</a></li>
																																				</ul>
							</li>
																																																															
																																	<li><a href="/my-32"><span>My 3.2</span></a>
									
								<ul class="sub-menu">
									<!-- <li><a href="/my-32">My 3.2</a> -->
																																							<li><a href="http://www.mynetworktv.com/" target="_blank">My Network TV</a></li>
																																				</ul>
							</li>
																																																																																																																																																											
																																	<li><a href="/on-kimt"><span>On KIMT</span></a>
									
								<ul class="sub-menu">
									<!-- <li><a href="/on-kimt">On KIMT</a> -->
																																							<li><a href="/on-kimt/contests">Contests</a></li>
																																																																												<li><a href="/on-kimt/whats-on">KIMT Programming</a></li>
																																																						</ul>
							</li>
																																																																																																																																																																																																																																																																																																																																																							
																																	<li><a href="/about-us"><span>About Us</span></a>
									
								<ul class="sub-menu">
									<!-- <li><a href="/about-us">About Us</a> -->
																																							<li><a href="/about-us/meet-the-news-team">Meet the News Team</a></li>
																																																										<li><a href="/about-us/management-and-sales">Management & Sales</a></li>
																																																										<li><a href="/about-us/history">History</a></li>
																																																										<li><a href="/about-us/kimt-jobs">Jobs</a></li>
																																																										<li><a href="/about-us/contact-us">Contact Us</a></li>
																																																										<li><a href="/about-us/digital-marketing">Digital Marketing</a></li>
																																																																												<li><a href="https://www.kimt.com/newsletter/" target="${subSection.target}">Newsletters</a></li>
																																																										<li><a href="/about-us/our-apps">Our Apps</a></li>
																																				</ul>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																			
																																	<li><a href="/community"><span>Community</span></a>
									
								<ul class="sub-menu">
									<!-- <li><a href="/community">Community</a> -->
																																							<li><a href="/community/giving-your-best-volunteer-of-the-month">Giving Your Best Volunteer of the Month</a></li>
																																																										<li><a href="/community/tools-for-schools">Tools for Schools</a></li>
																																																																												<li><a href="/community/golden-apple">Golden Apple</a></li>
																																																										<li><a href="/community/calendar">Community Calendar</a></li>
																																																										<li><a href="https://www.kimt.com/content/news/Meet-the-2019-20-KIMT-Scholastic-All-Stars-570776481.html" target="_parent">2019-20 Scholastic All-Stars</a></li>
																																																										<li><a href="/community/feeding-america">Feeding America</a></li>
																																																										<li><a href="/community/local-business">Local Business Directory</a></li>
																																																										<li><a href="/community/non-profits">Non-Profits</a></li>
																																																						</ul>
							</li>
																											
																																																
																																																
																																																
																																																
																																																
																																	
																																											</ul>
			</nav>
			<!-- Toolbar-->
			<div class="toolbar">
				<div class="inner">
					<div class="tools">
						<div class="search"><i class="icon-search"></i></div>
					</div>
				</div>
			</div>
		</header>
				<!-- false -->
<script>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</script>



<!-- /30582678/HTV/KIMT/bouncex -->
<div id='div-gpt-ad-1583333468063-0' style='width: 1px; height: 1px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1583333468063-0'); });
  </script>
</div>



<!-- CACHE TIMESTAMPS -->
	<!- 2019-12-31 11:00:03pm -->
	<!- 2019-09-10 09:05:01pm -->
	<!- 2019-09-10 09:00:02pm -->
	<!- 2019-09-10 08:55:02pm -->
	<!- 2019-09-10 08:50:02pm -->



  

 	
			
																
																					
							
							
							
						 			
																
																					
							
							
							
						 			
																
																					
							
							
							
						 			
																
																					
							
							
							
						 			
																
						 			
																
						 			
																
						 			
																
																															
							
							
							
						 			
																
						 	 	

  

 	
	 	

  

 	
	 	

  

 	
	 	

  

 	
	 	

		<!-- Off-Canvas Wrapper-->
		<div class="offcanvas-wrapper">
			<div class="container-fluid topContainer">
				<div class="midContainer">
				

		

<style>
	
.breakingTop {
    background-color: #cc0000;
    text-align:center;
    color: #fff;
    padding: 7px 3px 7px 3px;
    margin: 0px 0px 8px 0px;
    font-weight: bold;
    border-bottom-left-radius: 40px;
    border-bottom-right-radius: 40px;
    width: 100%;
    background: linear-gradient(#990000, #cc0000);
    min-height:35px;
	
}	

.breakingTop a {
    color: #fff;
    font-weight:normal;
    text-decoration:underline;
    }	


.navbar {
	border-bottom:0px;
	box-shadow: 2px 2px 2px #888;
	}
	
.noalert {padding-top:10px}

.alertsTop.cycle-slide.cycle-sentinel {
    height: 100%;
}
</style>
		 
	
		
	
																																
			
		
	
	<!-- Closings Bar: false --> 
	
	
			
	 					
 	
	
			<div id="alertsBar" class="breakingTop">
			<div class="cycle-slideshow" data-cycle-fx="fade" data-cycle-center-vert=true data-cycle-center-horz=true  data-cycle-timeout="3000" data-cycle-slides="> div">
			
										<div class="alertsTop"><i class="fa fa-video-camera" aria-hidden="true"></i> STREAMING NOW: <a href="/livestream"> Watch Now </a></div>
									</div>
			
		</div>
	

					<div class="row">
												<div class="col-xl-9 col-lg-8 col-md-7 sticky">
													<div class="theiaStickySidebar">
								<div class="dfpWrapper pb-4" style="width:100%">
									<div id='WNAd41' style="text-align:center">
									<script>googletag.cmd.push(function() { googletag.display('WNAd41'); });</script>
									</div>
								</div>
								
																																																
																																																													
																		<link rel="stylesheet" media="screen" href="https://www.kimt.com/includes/lightbox.css">	
<script src="https://www.kimt.com/includes/lightbox.js"></script>	
<script>$(document).on('click', '[data-toggle="lightbox"]', function(event) {
 event.preventDefault();
 $(this).ekkoLightbox();
   });
 </script>				 		
									<div class="tr-section" id="article">
										<div class="section-title title-before">
											<h1>Minnesota could free man serving life in child's 2002 death
												<span style="float:right">
													<a href="#" onclick="resizeText(1)" /><i class="fa fa-plus-square-o" aria-hidden="true"></i></a>
													<a href="#" onclick="resizeText(-1)" /><i class="fa fa-minus-square-o" aria-hidden="true"></i></a>
												</span>
											</h1>
										</div>
																				<div class="row mb-4" class="articleHead">
																																				<div class="col-lg-4">
																													<img src="https://media.heartlandtv.com/images/Minnesota+news+3.jpg" class="img-fluid" alt="" />
															<div><em></em></div>
																											</div>											
																																		<div class="col-lg-8">
												<p class="article-summary lead">Minnesota’s pardon board will consider freeing a Black man who was imprisoned for life as a teenager in the 2002 death of a girl who was hit by a stray bullet while doing homework at her dining room table. </p>
																								<div class="article-posted">Posted: Dec 15, 2020 2:30 PM</div>
													<!-- Dec 15, 2020 2:30 PM || Dec 15, 2020 2:30 PM || LiveDate: Tue Dec 15 12:30:02 PST 2020 -->
																																					

																									
													
													
													
													
													
													
													
																										<div class="article-author">Posted By: By ROBIN McDOWELL and MARGIE MASON Associated Press  </div>
																								<div class="addthis_inline_share_toolbox pt-2"></div>

												
																							</div>
										</div>
																				

										
										<div class="article-content">
										
																						
																											
																						
											
											<style>
											@media (min-width: 1024px){
												.extras {
													 max-width:100%;
												}
												
											@media (max-width: 9000px){
												.extras {
													max-width:320px;
													float:right;
												}
											}
											</style>
											<div class="row">
												<div class="col-lg-12">
												
																								
																																																					
														<p>MINNEAPOLIS (AP) &mdash; Minnesota&rsquo;s pardon board on Tuesday will consider freeing a Black man sentenced to life in prison as a teen in a high-profile murder case that has raised questions about the integrity of the criminal justice system that put him away.</p>
																																									
														<p>Myon Burrell&rsquo;s case made headlines earlier this year after The Associated Press and American Public Media uncovered new evidence and serious flaws in the police investigation into the 2002 killing of an 11-year-old girl who was hit by a stray bullet while doing homework at her dining room table.</p>
																																										<div class="extras ml-3 mr-3">
																																																																															</div>	
																												
														<p>Last week, an independent panel of national legal experts recommended his immediate release after reviewing the facts and all of the available evidence.</p>
																																									
														<p>Burrell will go before the Minnesota Board of Pardons, which will consider his request for a pardon and commutation.</p>
																																									
														<p>Both are extremely rare, especially in murder cases, partly because of the state&rsquo;s arduous process. A unanimous vote is normally required by the governor, attorney general and the chief Supreme Court justice. Chief Justice Lorie Skjerven Gildea has recused herself from the decision.</p>
																																									
														<p>Burrell was 16 when he was sentenced in the killing of Tyesha Edwards, a Black sixth grader who was shot through the heart inside her family&rsquo;s south Minneapolis home. Now 34, he has always maintained his innocence, and another man has confessed to being the shooter.</p>
																																									
														<p>The child&rsquo;s senseless death enraged the African American community, which was fed up with gang and gun violence, and that anger resonated long after the conviction. Sen. Amy Klobuchar, who was the city&rsquo;s top prosecutor at the time, has used Burrell&rsquo;s conviction throughout her political career to tout her record of being tough on crime. She raised it again last year on the stage of the Democratic presidential primary debate.</p>
																																									
														<p>The AP&rsquo;s yearlong investigation, however, showed there was no hard evidence &mdash; no gun, DNA or fingerprints &mdash; tying Burrell to the shooting. Among other things, police did not collect a corner store&rsquo;s surveillance video, which Burrell said could have cleared him. And video footage showed the lead homicide detective offering a man in police custody $500 for Burrell&rsquo;s name, even if it was just hearsay.</p>
																																									
														<p>Burrell&rsquo;s co-defendants said the teenager was not at the scene that day.</p>
																																									
														<p>New questions about Burrell&rsquo;s case surfaced just before Minneapolis was thrust into the national spotlight after a police officer held his knee against George Floyd&rsquo;s neck on the pavement outside Cup Foods until he eventually died &mdash; the same store Burrell said could have provided his alibi if surveillance tapes had been pulled. Floyd&rsquo;s death sparked racial injustice protests and put renewed focus on some law enforcement practices from the 1990s and early 2000s, when harsher policing and tougher sentencing led to the highest lock-up rates in the nation&rsquo;s history. Those incarcerations hit Black and brown communities the hardest.</p>
																																									
														<p>Under public pressure after the AP report, Klobuchar threw her support behind the creation of the independent panel, saying it was just as important to protect the innocent as punish the guilty. In its report, the panel raised concerns about the police investigation that mirrored many of those uncovered by the AP.</p>
																																									
														<p>The panel&rsquo;s report said officers suffered from &ldquo;tunnel vision&rdquo; while pursuing Burrell as a suspect, honing in on evidence that supported their theory of guilt and ignoring that which may have helped him. Officers relied heavily on a single eyewitness, who offered conflicting accounts, along with jailhouse informants, who benefited generously for testifying.</p>
																																									
														<p>Two of the informants have since recanted. One had his 16-year prison sentence cut down to three. Another said he was cooperating with police in 14 other cases.</p>
																																									
														<p>The panel said it saw no purpose served by keeping Burrell locked up. It pointed to his age at the time of the crime, said he had no prior record and that he behaved well behind bars. It also cited U.S. Supreme Court rulings in recent years that argued against overly harsh sentences for juveniles because their brains and decision-making skills are not fully developed.</p>
																																									
														<p>&ldquo;In considering the sentence, we became profoundly aware of how our nation has changed in the way we consider juveniles who become enmeshed in the criminal justice system,&rdquo; Mark Osler, who chaired the panel, wrote in the Minneapolis Star Tribune this past weekend.</p>
																																									
														<p>Burrell was jailed during an era &ldquo;marked by racially charged fearmongering about young &lsquo;super-predators&rsquo; who would be violent for the entirety of their lives,&rdquo; Osler wrote.</p>
																																									
														<p>In the panel&rsquo;s report, members of Tyesha Edwards&rsquo; family said Burrell&rsquo;s continued imprisonment was a sensitive topic.</p>
																																									
														<p>The girl&rsquo;s biological father, Jimmie Edwards, said he opposed any release and that the process of having the case reexamined has been taxing. He said Tyesha had been doing well in school and was well-liked by classmates and teachers.</p>
																																									
														<p>&ldquo;He just wants a free ticket out of prison,&rdquo; he told AP. &ldquo;But he took something from us that can never be replaced.&rdquo;</p>
																									</div>
											</div>
																																																																		<div style="max-width:600px" class="mt-3 mb-3">


<script id="5caf9618038e419c80d49105ba54c216">
  cnxps.cmd.push(function () {
    cnxps({
      playerId: "3e467e52-ebce-4794-a0de-233fe9f74067"
    }).render("5caf9618038e419c80d49105ba54c216");
  });
</script>
 









</div>
</div>


											<div class="row">
												<div class="col-sm-6">
																																																									
																															<h3>Related Content</h3>
																<!-- Searching: /content/news -->
																<ul>
																																		
																	
																	
																	
																	
																	
																	
																																																						<li><a href="https://www.kimt.com/content/news/Minnesota-could-free-man-serving-life-in-childs-2002-death-573400091.html">Minnesota could free man serving life in child's 2002 death</a></li>
																																																																								<li><a href="https://www.kimt.com/content/news/Cabin-Fever-2002-vs-Cabin-Fever-2016-488796941.html">Cabin Fever (2002) vs. Cabin Fever (2016)</a></li>
																																																																								<li><a href="https://www.kimt.com/content/news/Legal-experts-say-Minnesota-man-serving-life-sentence-should-be-freed-573335861.html">Legal experts say Minnesota man serving life sentence should be freed</a></li>
																																																																								<li><a href="https://www.kimt.com/content/news/Minnesota-man-gets-double-life-sentences-461346613.html">Minnesota man gets double life sentences</a></li>
																																																																								<li><a href="https://www.kimt.com/content/news/NE-Iowa-man-serving-life-for-infants-gruesome-death-loses-appeal-572980391.html">NE Iowa man serving life for infant's gruesome death loses appeal</a></li>
																																																																								<li><a href="https://www.kimt.com/content/news/Minnesota-considering-going-hands-free-482437651.html">Minnesota considering going 'hands free'</a></li>
																																																																								<li><a href="https://www.kimt.com/content/news/Flu-blames-for-another-child-death-in-Minnesota-475572553.html">Flu blamed for another child death in Minnesota</a></li>
																																																																								<li><a href="https://www.kimt.com/content/news/Seasons-first-flu-related-child-death-reported-in-Minnesota-567237321.html">Season's first flu-related child death reported in Minnesota</a></li>
																																																																								<li><a href="https://www.kimt.com/content/news/Minnesota-reports-its-1st-COVID-related-death-of-child-571836361.html">Minnesota reports its 1st COVID-related death of child</a></li>
																																																																								<li><a href="https://www.kimt.com/content/news/Minnesota-man-charged-in-wifes-overdose-death-507137551.html">Minnesota man charged in wife's overdose death</a></li>
																																																			</ul>
																																																						</div>
												<div class="col-sm-6">
																											<div class="text-center float-sm-none mx-auto">
															<div class="hidden-sm-up"><em><small>Scroll for more content...</small></em></div>
															<div class="dfpWrapper pb-4 pt-4">
																<div class="col-12" id='div-gpt-ad-article' style="width:100%; text-align:center">
																	<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-article'); });</script>
																</div>
															</div>
														</div>
																									</div>
											</div>

																				
																						<script async src="https://launcher.spot.im/spot/sp_NTDzHEz3"
												data-spotim-module="spotim-launcher"
												data-post-url="https://www.kimt.com/content/news/Minnesota-could-free-man-serving-life-in-childs-2002-death-573400091.html"
												data-article-tags=""    
												data-post-id="573400091"
												data-facebook-url="https://www.kimt.com/content/news/Minnesota-could-free-man-serving-life-in-childs-2002-death-573400091.html"></script>
											
<div data-spotim-module="pitc"></div>

			

										

										
										<div id="nativoPlacement"></div>
									</div>
 

																
								
							</div>
						</div>
												<div class="col-xl-3 col-lg-4 col-md-5 sticky">
							<div class="theiaStickySidebar">
								<!-- Right Column = /home -->









																	<div class="tr-section">
													<div class="section-title title-before">
								<h1>Minnesota Coronavirus Cases</h1>
							</div>
																			<p><p><b>Data is updated nightly.</b></p></p>
																															
<h4>Cases: 381841</h4><h5>Reported Deaths: 4521</h5><button class='btn btn-block btn-secondary' data-toggle='collapse' data-target='#M_Minnesota'>View Counties</button><div id='M_Minnesota' class='collapse'><table class='table table-striped'><tr><th>County</th><th>Cases</th><th>Deaths</th></tr><tr><td>Hennepin</td><td>79756</td><td>1246</td></tr><tr><td>Ramsey</td><td>34016</td><td>592</td></tr><tr><td>Dakota</td><td>27388</td><td>236</td></tr><tr><td>Anoka</td><td>26802</td><td>263</td></tr><tr><td>Washington</td><td>16968</td><td>150</td></tr><tr><td>Stearns</td><td>16011</td><td>145</td></tr><tr><td>St. Louis</td><td>11245</td><td>158</td></tr><tr><td>Scott</td><td>10160</td><td>71</td></tr><tr><td>Wright</td><td>9939</td><td>66</td></tr><tr><td>Olmsted</td><td>8159</td><td>46</td></tr><tr><td>Sherburne</td><td>7066</td><td>49</td></tr><tr><td>Carver</td><td>5928</td><td>22</td></tr><tr><td>Clay</td><td>5799</td><td>69</td></tr><tr><td>Kandiyohi</td><td>5047</td><td>47</td></tr><tr><td>Rice</td><td>4916</td><td>46</td></tr><tr><td>Blue Earth</td><td>4710</td><td>22</td></tr><tr><td>Crow Wing</td><td>4265</td><td>48</td></tr><tr><td>Otter Tail</td><td>3893</td><td>37</td></tr><tr><td>Chisago</td><td>3794</td><td>24</td></tr><tr><td>Benton</td><td>3589</td><td>65</td></tr><tr><td>Nobles</td><td>3395</td><td>41</td></tr><tr><td>Winona</td><td>3315</td><td>39</td></tr><tr><td>Douglas</td><td>3191</td><td>50</td></tr><tr><td>Mower</td><td>3105</td><td>23</td></tr><tr><td>Polk</td><td>3061</td><td>40</td></tr><tr><td>McLeod</td><td>2855</td><td>30</td></tr><tr><td>Morrison</td><td>2756</td><td>36</td></tr><tr><td>Goodhue</td><td>2649</td><td>35</td></tr><tr><td>Beltrami</td><td>2627</td><td>28</td></tr><tr><td>Lyon</td><td>2612</td><td>23</td></tr><tr><td>Becker</td><td>2505</td><td>29</td></tr><tr><td>Itasca</td><td>2453</td><td>29</td></tr><tr><td>Isanti</td><td>2409</td><td>25</td></tr><tr><td>Carlton</td><td>2367</td><td>29</td></tr><tr><td>Steele</td><td>2346</td><td>9</td></tr><tr><td>Todd</td><td>2114</td><td>19</td></tr><tr><td>Pine</td><td>1994</td><td>10</td></tr><tr><td>Nicollet</td><td>1906</td><td>30</td></tr><tr><td>Mille Lacs</td><td>1884</td><td>38</td></tr><tr><td>Brown</td><td>1828</td><td>23</td></tr><tr><td>Freeborn</td><td>1791</td><td>14</td></tr><tr><td>Le Sueur</td><td>1786</td><td>13</td></tr><tr><td>Cass</td><td>1772</td><td>13</td></tr><tr><td>Meeker</td><td>1754</td><td>22</td></tr><tr><td>Waseca</td><td>1568</td><td>11</td></tr><tr><td>Roseau</td><td>1523</td><td>9</td></tr><tr><td>Martin</td><td>1429</td><td>23</td></tr><tr><td>Wabasha</td><td>1347</td><td>2</td></tr><tr><td>Hubbard</td><td>1300</td><td>33</td></tr><tr><td>Redwood</td><td>1210</td><td>22</td></tr><tr><td>Renville</td><td>1184</td><td>34</td></tr><tr><td>Chippewa</td><td>1144</td><td>18</td></tr><tr><td>Cottonwood</td><td>1142</td><td>5</td></tr><tr><td>Dodge</td><td>1058</td><td>3</td></tr><tr><td>Wadena</td><td>1024</td><td>9</td></tr><tr><td>Houston</td><td>996</td><td>5</td></tr><tr><td>Watonwan</td><td>995</td><td>5</td></tr><tr><td>Rock</td><td>966</td><td>10</td></tr><tr><td>Sibley</td><td>936</td><td>4</td></tr><tr><td>Aitkin</td><td>929</td><td>31</td></tr><tr><td>Fillmore</td><td>928</td><td>0</td></tr><tr><td>Kanabec</td><td>855</td><td>18</td></tr><tr><td>Pipestone</td><td>836</td><td>18</td></tr><tr><td>Pennington</td><td>832</td><td>10</td></tr><tr><td>Yellow Medicine</td><td>795</td><td>13</td></tr><tr><td>Faribault</td><td>778</td><td>5</td></tr><tr><td>Swift</td><td>743</td><td>13</td></tr><tr><td>Murray</td><td>705</td><td>5</td></tr><tr><td>Jackson</td><td>691</td><td>3</td></tr><tr><td>Pope</td><td>650</td><td>3</td></tr><tr><td>Marshall</td><td>630</td><td>11</td></tr><tr><td>Stevens</td><td>624</td><td>5</td></tr><tr><td>Clearwater</td><td>611</td><td>10</td></tr><tr><td>Wilkin</td><td>535</td><td>5</td></tr><tr><td>Lac qui Parle</td><td>519</td><td>8</td></tr><tr><td>Koochiching</td><td>497</td><td>7</td></tr><tr><td>Lake</td><td>497</td><td>11</td></tr><tr><td>Unassigned</td><td>488</td><td>59</td></tr><tr><td>Lincoln</td><td>427</td><td>1</td></tr><tr><td>Big Stone</td><td>407</td><td>2</td></tr><tr><td>Norman</td><td>399</td><td>7</td></tr><tr><td>Mahnomen</td><td>361</td><td>6</td></tr><tr><td>Grant</td><td>346</td><td>7</td></tr><tr><td>Kittson</td><td>325</td><td>14</td></tr><tr><td>Red Lake</td><td>275</td><td>3</td></tr><tr><td>Traverse</td><td>176</td><td>2</td></tr><tr><td>Lake of the Woods</td><td>137</td><td>1</td></tr><tr><td>Cook</td><td>97</td><td>0</td></tr></table></div>


											</div>
																										<div class="tr-section">
													<div class="section-title title-before">
								<h1>Iowa Coronavirus Cases</h1>
							</div>
																			<p><p><b>Data is updated nightly.</b></p></p>
																															
<h4>Cases: 255853</h4><h5>Reported Deaths: 3225</h5><button class='btn btn-block btn-secondary' data-toggle='collapse' data-target='#M_Iowa'>View Counties</button><div id='M_Iowa' class='collapse'><table class='table table-striped'><tr><th>County</th><th>Cases</th><th>Deaths</th></tr><tr><td>Polk</td><td>37732</td><td>371</td></tr><tr><td>Linn</td><td>15498</td><td>217</td></tr><tr><td>Scott</td><td>12968</td><td>118</td></tr><tr><td>Black Hawk</td><td>11855</td><td>189</td></tr><tr><td>Woodbury</td><td>11480</td><td>145</td></tr><tr><td>Johnson</td><td>10358</td><td>43</td></tr><tr><td>Dubuque</td><td>10014</td><td>125</td></tr><tr><td>Pottawattamie</td><td>7483</td><td>78</td></tr><tr><td>Story</td><td>7431</td><td>23</td></tr><tr><td>Dallas</td><td>7179</td><td>60</td></tr><tr><td>Webster</td><td>4073</td><td>48</td></tr><tr><td>Sioux</td><td>4070</td><td>39</td></tr><tr><td>Cerro Gordo</td><td>4019</td><td>49</td></tr><tr><td>Clinton</td><td>3770</td><td>49</td></tr><tr><td>Marshall</td><td>3759</td><td>53</td></tr><tr><td>Buena Vista</td><td>3374</td><td>19</td></tr><tr><td>Muscatine</td><td>3310</td><td>63</td></tr><tr><td>Warren</td><td>3304</td><td>25</td></tr><tr><td>Des Moines</td><td>3271</td><td>26</td></tr><tr><td>Plymouth</td><td>3111</td><td>40</td></tr><tr><td>Wapello</td><td>2869</td><td>87</td></tr><tr><td>Lee</td><td>2570</td><td>20</td></tr><tr><td>Jasper</td><td>2550</td><td>48</td></tr><tr><td>Jones</td><td>2475</td><td>33</td></tr><tr><td>Marion</td><td>2333</td><td>33</td></tr><tr><td>Henry</td><td>2302</td><td>19</td></tr><tr><td>Carroll</td><td>2182</td><td>25</td></tr><tr><td>Bremer</td><td>2137</td><td>35</td></tr><tr><td>Crawford</td><td>1933</td><td>16</td></tr><tr><td>Benton</td><td>1868</td><td>31</td></tr><tr><td>Jackson</td><td>1674</td><td>23</td></tr><tr><td>Boone</td><td>1646</td><td>14</td></tr><tr><td>Washington</td><td>1633</td><td>24</td></tr><tr><td>Tama</td><td>1631</td><td>55</td></tr><tr><td>Dickinson</td><td>1573</td><td>12</td></tr><tr><td>Delaware</td><td>1551</td><td>27</td></tr><tr><td>Mahaska</td><td>1462</td><td>31</td></tr><tr><td>Clay</td><td>1413</td><td>10</td></tr><tr><td>Wright</td><td>1413</td><td>11</td></tr><tr><td>Kossuth</td><td>1374</td><td>23</td></tr><tr><td>Buchanan</td><td>1328</td><td>15</td></tr><tr><td>Hardin</td><td>1325</td><td>21</td></tr><tr><td>Hamilton</td><td>1314</td><td>21</td></tr><tr><td>Page</td><td>1286</td><td>10</td></tr><tr><td>Clayton</td><td>1263</td><td>25</td></tr><tr><td>Harrison</td><td>1254</td><td>49</td></tr><tr><td>Cedar</td><td>1250</td><td>15</td></tr><tr><td>Winneshiek</td><td>1212</td><td>15</td></tr><tr><td>Mills</td><td>1199</td><td>11</td></tr><tr><td>Floyd</td><td>1197</td><td>25</td></tr><tr><td>Fayette</td><td>1190</td><td>14</td></tr><tr><td>Butler</td><td>1154</td><td>15</td></tr><tr><td>Lyon</td><td>1142</td><td>21</td></tr><tr><td>Calhoun</td><td>1134</td><td>8</td></tr><tr><td>Poweshiek</td><td>1104</td><td>21</td></tr><tr><td>Cherokee</td><td>1084</td><td>15</td></tr><tr><td>Iowa</td><td>1064</td><td>19</td></tr><tr><td>Winnebago</td><td>1031</td><td>26</td></tr><tr><td>Hancock</td><td>1027</td><td>21</td></tr><tr><td>Allamakee</td><td>1017</td><td>18</td></tr><tr><td>Sac</td><td>974</td><td>10</td></tr><tr><td>Chickasaw</td><td>965</td><td>9</td></tr><tr><td>Louisa</td><td>963</td><td>23</td></tr><tr><td>Grundy</td><td>949</td><td>14</td></tr><tr><td>Union</td><td>945</td><td>11</td></tr><tr><td>Cass</td><td>928</td><td>36</td></tr><tr><td>Mitchell</td><td>909</td><td>19</td></tr><tr><td>Emmet</td><td>883</td><td>23</td></tr><tr><td>Appanoose</td><td>877</td><td>33</td></tr><tr><td>Humboldt</td><td>862</td><td>16</td></tr><tr><td>Shelby</td><td>861</td><td>20</td></tr><tr><td>Guthrie</td><td>849</td><td>22</td></tr><tr><td>Jefferson</td><td>848</td><td>13</td></tr><tr><td>Madison</td><td>834</td><td>8</td></tr><tr><td>Franklin</td><td>816</td><td>17</td></tr><tr><td>Palo Alto</td><td>749</td><td>2</td></tr><tr><td>Keokuk</td><td>723</td><td>18</td></tr><tr><td>Pocahontas</td><td>639</td><td>4</td></tr><tr><td>Ida</td><td>638</td><td>17</td></tr><tr><td>Howard</td><td>631</td><td>15</td></tr><tr><td>Montgomery</td><td>620</td><td>13</td></tr><tr><td>Osceola</td><td>590</td><td>5</td></tr><tr><td>Greene</td><td>585</td><td>6</td></tr><tr><td>Davis</td><td>580</td><td>12</td></tr><tr><td>Unassigned</td><td>577</td><td>0</td></tr><tr><td>Clarke</td><td>551</td><td>6</td></tr><tr><td>Adair</td><td>513</td><td>16</td></tr><tr><td>Monroe</td><td>513</td><td>15</td></tr><tr><td>Monona</td><td>507</td><td>12</td></tr><tr><td>Taylor</td><td>501</td><td>8</td></tr><tr><td>Worth</td><td>435</td><td>2</td></tr><tr><td>Fremont</td><td>426</td><td>5</td></tr><tr><td>Van Buren</td><td>419</td><td>11</td></tr><tr><td>Lucas</td><td>402</td><td>6</td></tr><tr><td>Decatur</td><td>373</td><td>2</td></tr><tr><td>Wayne</td><td>337</td><td>21</td></tr><tr><td>Audubon</td><td>329</td><td>6</td></tr><tr><td>Ringgold</td><td>317</td><td>5</td></tr><tr><td>Adams</td><td>212</td><td>2</td></tr></table></div>


											</div>
																										<div class="tr-section">
																																					<style>
</style>



	<div class="cycle-slideshow" data-cycle-fx="fade" data-cycle-loader="wait" data-cycle-timeout="4000" data-cycle-slides="> .wxRotate">
					<div class="wxRotate"><div class='city'><b>Rochester</b></div><div class='row'><div class='col-6'><div class='sky'>Few Clouds</div><div class='temperature'>22&deg; <img alt='wxIcon' class='wxicon' src='https://media.heartlandtv.com/designimages/wx_66.png' /></div></div><div class='col-6 text-left'><div class='hilo'>Hi: 23&deg; Lo: 15&deg;</div><div class='Wind'>Feels Like: 13&deg;</div><div><a class='wxlink' href='/weather'>More Weather</a></div></div></div></div>
					<div class="wxRotate"><div class='city'><b>Mason City</b></div><div class='row'><div class='col-6'><div class='sky'>Clear</div><div class='temperature'>23&deg; <img alt='wxIcon' class='wxicon' src='https://media.heartlandtv.com/designimages/wx_85.png' /></div></div><div class='col-6 text-left'><div class='hilo'>Hi: 24&deg; Lo: 14&deg;</div><div class='Wind'>Feels Like: 15&deg;</div><div><a class='wxlink' href='/weather'>More Weather</a></div></div></div></div>
					<div class="wxRotate"><div class='city'><b>Albert Lea</b></div><div class='row'><div class='col-6'><div class='sky'>Clear</div><div class='temperature'>25&deg; <img alt='wxIcon' class='wxicon' src='https://media.heartlandtv.com/designimages/wx_85.png' /></div></div><div class='col-6 text-left'><div class='hilo'>Hi: 26&deg; Lo: 14&deg;</div><div class='Wind'>Feels Like: 18&deg;</div><div><a class='wxlink' href='/weather'>More Weather</a></div></div></div></div>
					<div class="wxRotate"><div class='city'><b>Austin</b></div><div class='row'><div class='col-6'><div class='sky'>Clear</div><div class='temperature'>25&deg; <img alt='wxIcon' class='wxicon' src='https://media.heartlandtv.com/designimages/wx_85.png' /></div></div><div class='col-6 text-left'><div class='hilo'>Hi: 26&deg; Lo: 15&deg;</div><div class='Wind'>Feels Like: 25&deg;</div><div><a class='wxlink' href='/weather'>More Weather</a></div></div></div></div>
					<div class="wxRotate"><div class='city'><b>Charles City</b></div><div class='row'><div class='col-6'><div class='sky'>Overcast</div><div class='temperature'>23&deg; <img alt='wxIcon' class='wxicon' src='https://media.heartlandtv.com/designimages/wx_67.png' /></div></div><div class='col-6 text-left'><div class='hilo'>Hi: 26&deg; Lo: 15&deg;</div><div class='Wind'>Feels Like: 16&deg;</div><div><a class='wxlink' href='/weather'>More Weather</a></div></div></div></div>
			</div>


	
		
	
	<div style="font-size:1em; padding:15px 5px; clear:both">
		A Few Snow Chances
	</div>

	<div class="dfpWrapper pt-1 pb-1" style="width:100%">
		<div id='div-gpt-ad-weatherbox' style="text-align:center">
			<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-weatherbox');});</script>
		</div>
	</div>		
	
	<div id="accordion">
		<div class="card">
		<div class="card-header" id="1">
			<h5 class="mb-0">
				<button class="btn btn-link btn-block" data-toggle="collapse" data-target="#Radar" aria-expanded="true" aria-controls="collapseOne">
				  Radar <i class="fa fa-angle-down" aria-hidden="true"></i>
				</button>
			</h5>
		</div>

		<div id="Radar" class="collapse  show " aria-label="Radar" data-parent="#accordion">
			<div class="card-body">
								<a href="https://www.kimt.com/weather/maps-radars/?image=https://ftp2.kimt.com/weather03.gif&title=Local%20Radar"><img src="https://ftp2.kimt.com/weather03.jpg" class="img img-fluid" alt="KIMT Radar" /></a>
							</div>
		</div>
	</div>
		<div class="card">
		<div class="card-header" id="2">
			<h5 class="mb-0">
				<button class="btn btn-link btn-block" data-toggle="collapse" data-target="#Eye_in_the_sky" aria-expanded="true" aria-controls="collapseOne">
				  Eye in the sky <i class="fa fa-angle-down" aria-hidden="true"></i>
				</button>
			</h5>
		</div>

		<div id="Eye_in_the_sky" class="collapse " aria-label="Eye in the sky" data-parent="#accordion">
			<div class="card-body">
								<a href="https://www.kimt.com/weather/eye-in-the-sky/"><img src="https://ftp2.kimt.com/austin.jpg " class="img img-fluid" alt="KIMT Eye in the sky" /></a>
							</div>
		</div>
	</div>
		</div>
		

											</div>
																										<div class="text-center" style="margin-bottom:30px">
						<div class="dfpWrapper">
							<div id='div-gpt-ad-right0' style="text-align:center">
								<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-right0'); });</script>
							</div>
						</div>
					</div>
																										<div class="tr-section">
													<div class="section-title title-before">
								<h1>Most Popular Stories</h1>
							</div>
																																					
<style>

.entry {margin:8px 0px}

.entry-thumb {
    width: 100px;
    padding-right: 12px;
}

.entry-thumb>a {
    display: block;
    overflow: hidden;
}

.entry-thumb>a>img {
    width: 100%;
}

.entry-thumb, .entry-content {
    display: table-cell;
    vertical-align: middle;
}

h4.entry-title {font-size:14px}

</style>




<div class="tr-section" id="mostPopular">
		
			<div class="entry">
		<div class="entry-thumb">
			<a href="https://www.kimt.com/content/news/Governor-orders-21-million-returned-to-Iowa-COVID-relief-fund-573390891.html">
									<img src="https://media.heartlandtv.com/images/100*56/Kim+Reynolds+good+for+web+1.jpg"  class="img-responsive" alt="${article.thumbnail.title}" />
							</a>
		</div>
		<div class="entry-content">
     	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/news/Governor-orders-21-million-returned-to-Iowa-COVID-relief-fund-573390891.html">Governor orders $21 million returned to Iowa COVID relief fund</a></h4><span class="entry-meta"></span>
  		</div>
  	</div>
		
				<div class="entry">
		<div class="entry-thumb">
			<a href="https://www.kimt.com/content/news/Serious-assault-investigation-underway-in-Austin-573396691.html">
									<img src="https://media.heartlandtv.com/images/100*56/Austin+assault+jan+15.jpg"  class="img-responsive" alt="${article.thumbnail.title}" />
							</a>
		</div>
		<div class="entry-content">
     	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/news/Serious-assault-investigation-underway-in-Austin-573396691.html">2 with life-threatening injuries, 1 in custody after 'serious assault'  in Austin</a></h4><span class="entry-meta"></span>
  		</div>
  	</div>
		
			<div class="entry">
		<div class="entry-thumb">
			<a href="https://www.kimt.com/content/news/Second-guilty-plea-in-burglary-at-Newman-Catholic-School-573389481.html">
									<img src="https://media.heartlandtv.com/images/100*56/Francis+and+Pope.jpg"  class="img-responsive" alt="${article.thumbnail.title}" />
							</a>
		</div>
		<div class="entry-content">
     	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/news/Second-guilty-plea-in-burglary-at-Newman-Catholic-School-573389481.html">Second guilty plea in burglary at Newman Catholic School</a></h4><span class="entry-meta"></span>
  		</div>
  	</div>
		
			<div class="entry">
		<div class="entry-thumb">
			<a href="https://www.kimt.com/content/news/Hormel-Foods-buying-thousands-of-meals-from-Austin-restaurants-573388921.html">
									<img src="https://media.heartlandtv.com/images/100*56/Hormel+graphic+3.jpg"  class="img-responsive" alt="${article.thumbnail.title}" />
							</a>
		</div>
		<div class="entry-content">
     	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/news/Hormel-Foods-buying-thousands-of-meals-from-Austin-restaurants-573388921.html">Hormel Foods buying thousands of meals from Austin restaurants</a></h4><span class="entry-meta"></span>
  		</div>
  	</div>
		
			<div class="entry">
		<div class="entry-thumb">
			<a href="https://www.kimt.com/content/news/Mason-City-man-sent-to-prison-for-prostitution-573391061.html">
									<img src="https://media.heartlandtv.com/images/100*56/James+Heginger.jpg"  class="img-responsive" alt="${article.thumbnail.title}" />
							</a>
		</div>
		<div class="entry-content">
     	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/news/Mason-City-man-sent-to-prison-for-prostitution-573391061.html">Mason City man sent to prison for prostitution</a></h4><span class="entry-meta"></span>
  		</div>
  	</div>
		
			<div class="entry">
		<div class="entry-thumb">
			<a href="https://www.kimt.com/content/news/Mason-City-man-arrested-for-eluding-authorities-in-Worth-County-573397491.html">
									<img src="https://media.heartlandtv.com/images/100*56/Jeffrey+Hook+3.jpg"  class="img-responsive" alt="${article.thumbnail.title}" />
							</a>
		</div>
		<div class="entry-content">
     	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/news/Mason-City-man-arrested-for-eluding-authorities-in-Worth-County-573397491.html">Mason City man arrested for eluding authorities in Worth County</a></h4><span class="entry-meta"></span>
  		</div>
  	</div>
		
			<div class="entry">
		<div class="entry-thumb">
			<a href="https://www.kimt.com/content/news/Coronavirus-A-timeline-in-Minnesota-and-Iowa-568898111.html">
									<img src="https://media.heartlandtv.com/images/100*56/Coronavirus+web+good++33.jpg"  class="img-responsive" alt="${article.thumbnail.title}" />
							</a>
		</div>
		<div class="entry-content">
     	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/news/Coronavirus-A-timeline-in-Minnesota-and-Iowa-568898111.html">Tracking local coronavirus numbers: Olmsted Co. goes over 8,000 total cases; Cerro Gordo Co. eclipses 50 deaths</a></h4><span class="entry-meta"></span>
  		</div>
  	</div>
		
			<div class="entry">
		<div class="entry-thumb">
			<a href="https://www.kimt.com/content/news/MercyOne-planning-on-vaccine-being-in-north-Iowa-early-next-week-573389731.html">
									<img src="https://media.heartlandtv.com/images/100*56/Mercy+One+graphic+good.jpg"  class="img-responsive" alt="${article.thumbnail.title}" />
							</a>
		</div>
		<div class="entry-content">
     	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/news/MercyOne-planning-on-vaccine-being-in-north-Iowa-early-next-week-573389731.html">MercyOne planning on vaccine being in north Iowa early next week</a></h4><span class="entry-meta"></span>
  		</div>
  	</div>
		
			<div class="entry">
		<div class="entry-thumb">
			<a href="https://www.kimt.com/content/news/2-arrested-in-connection-to-armed-robberies-throughout-Mower-Co-573388571.html">
									<img src="https://media.heartlandtv.com/images/100*56/Austin+robbery+mugs.jpg"  class="img-responsive" alt="${article.thumbnail.title}" />
							</a>
		</div>
		<div class="entry-content">
     	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/news/2-arrested-in-connection-to-armed-robberies-throughout-Mower-Co-573388571.html">Three arrested in connection to string of armed robberies throughout Mower Co.</a></h4><span class="entry-meta"></span>
  		</div>
  	</div>
		
			<div class="entry">
		<div class="entry-thumb">
			<a href="https://www.kimt.com/content/news/No-charges-in-fatal-shooting-during-George-Floyd-riots-in-MInneapolis-573392781.html">
									<img src="https://media.heartlandtv.com/images/100*66/AP_20150668266816.jpg"  class="img-responsive" alt="${article.thumbnail.title}" />
							</a>
		</div>
		<div class="entry-content">
     	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/news/No-charges-in-fatal-shooting-during-George-Floyd-riots-in-MInneapolis-573392781.html">No charges in fatal shooting during George Floyd riots in MInneapolis</a></h4><span class="entry-meta"></span>
  		</div>
  	</div>
	</div>
						
									
				
			


											</div>
																										<div class="text-center" style="margin-bottom:30px">
						<div class="dfpWrapper">
							<div id='div-gpt-ad-right1' style="text-align:center">
								<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-right1'); });</script>
							</div>
						</div>
					</div>
																										<div class="tr-section">
													<div class="section-title title-before">
								<h1>Latest Video</h1>
							</div>
																																					

<style>

.entry {margin:8px 0px}

.entry-thumb {
    width: 100px;
    padding-right: 12px;
}

.entry-thumb>a {
    display: block;
    overflow: hidden;
}

.entry-thumb>a>img {
    width: 100%;
}

.entry-thumb, .entry-content {
    display: table-cell;
    vertical-align: middle;
}

h4.entry-title {font-size:14px}

</style>


							<div class="entry">
			<div class="entry-thumb">
				<a href="https://www.kimt.com/content/video/573400351.html">
											<img src="https://video-static-01.clipsyndicate.com/845f/2020/12/15/20/56/644ea311af22443681aa2d05577ff1bc.jpg?co_id=481" alt="Image">
									</a>
			</div>
       			<div class="entry-content">
             	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/video/573400351.html">2 serious injures in Austin</a></h4><span class="entry-meta"></span>
      	  		</div>
      	  	</div>
        						<div class="entry">
			<div class="entry-thumb">
				<a href="https://www.kimt.com/content/video/573395251.html">
											<img src="https://video-static-01.clipsyndicate.com/704d/2020/12/15/13/25/6269b611a3d342b89d23dfecd602ff6c.jpg?co_id=481" alt="Image">
									</a>
			</div>
       			<div class="entry-content">
             	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/video/573395251.html">"Small Business Takeover" supports local businesses impacted by the pandemic</a></h4><span class="entry-meta"></span>
      	  		</div>
      	  	</div>
        						<div class="entry">
			<div class="entry-thumb">
				<a href="https://www.kimt.com/content/video/573395231.html">
											<img src="https://video-static-01.clipsyndicate.com/18d6/2020/12/15/13/19/6df9b07fdd7d4c3bbb542f0f841c84f1.jpg?co_id=481" alt="Image">
									</a>
			</div>
       			<div class="entry-content">
             	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/video/573395231.html">Jack's Bottle Shop set to open in Rochester Thursday</a></h4><span class="entry-meta"></span>
      	  		</div>
      	  	</div>
        				<div class="entry">
			<div class="entry-thumb">
				<a href="https://www.kimt.com/content/video/Rochester-Lowers-Speed-Limits-on-Residential-Roads-573394351.html">
											<img src="https://video-static-01.clipsyndicate.com/18d6/2020/12/15/13/19/6df9b07fdd7d4c3bbb542f0f841c84f1.jpg?co_id=481" alt="Image">
									</a>
			</div>
       			<div class="entry-content">
             	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/video/Rochester-Lowers-Speed-Limits-on-Residential-Roads-573394351.html">Rochester Lowers Speed Limits on Residential Roads</a></h4><span class="entry-meta"></span>
      	  		</div>
      	  	</div>
        						<div class="entry">
			<div class="entry-thumb">
				<a href="https://www.kimt.com/content/video/573394331.html">
											<img src="https://video-static-01.clipsyndicate.com/5345/2020/12/15/05/27/bbc5ffefb09442129b0c999a42105ce2.jpg?co_id=481" alt="Image">
									</a>
			</div>
       			<div class="entry-content">
             	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/video/573394331.html">Rochester City Council Lowers Residential Speed Limtis</a></h4><span class="entry-meta"></span>
      	  		</div>
      	  	</div>
        				<div class="entry">
			<div class="entry-thumb">
				<a href="https://www.kimt.com/content/video/City-Council-Approves-Liquor-License-Fee-Relief-Program-573394271.html">
											<img src="https://video-static-01.clipsyndicate.com/5345/2020/12/15/05/27/bbc5ffefb09442129b0c999a42105ce2.jpg?co_id=481" alt="Image">
									</a>
			</div>
       			<div class="entry-content">
             	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/video/City-Council-Approves-Liquor-License-Fee-Relief-Program-573394271.html">Rochester City Council approves liquor license fee relief program</a></h4><span class="entry-meta"></span>
      	  		</div>
      	  	</div>
        						<div class="entry">
			<div class="entry-thumb">
				<a href="https://www.kimt.com/content/video/573394171.html">
											<img src="https://video-static-01.clipsyndicate.com/e83a/2020/12/15/04/48/77630d6bb53c493b9f4f587730646979.jpg?co_id=481" alt="Image">
									</a>
			</div>
       			<div class="entry-content">
             	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/video/573394171.html">Geminid  Meteor Shower</a></h4><span class="entry-meta"></span>
      	  		</div>
      	  	</div>
        						<div class="entry">
			<div class="entry-thumb">
				<a href="https://www.kimt.com/content/video/573394141.html">
											<img src="https://video-static-01.clipsyndicate.com/dbac/2020/12/15/04/47/ebaf8449a5a34a88bc1addc4755ac82d.jpg?co_id=481" alt="Image">
									</a>
			</div>
       			<div class="entry-content">
             	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/video/573394141.html">ake City's Nate Heise talks freshman season at UNI, playing during a pandemic</a></h4><span class="entry-meta"></span>
      	  		</div>
      	  	</div>
        						<div class="entry">
			<div class="entry-thumb">
				<a href="https://www.kimt.com/content/video/573394111.html">
											<img src="https://video-static-01.clipsyndicate.com/c227/2020/12/15/04/38/c918441fc13748d2b207556562170d4a.jpg?co_id=481" alt="Image">
									</a>
			</div>
       			<div class="entry-content">
             	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/video/573394111.html">Aaron's chilly forecast</a></h4><span class="entry-meta"></span>
      	  		</div>
      	  	</div>
        						<div class="entry">
			<div class="entry-thumb">
				<a href="https://www.kimt.com/content/video/573394071.html">
											<img src="https://video-static-01.clipsyndicate.com/89f2/2020/12/15/04/31/c9cbb5229ee04de3b79def3a04607f17.jpg?co_id=481" alt="Image">
									</a>
			</div>
       			<div class="entry-content">
             	  		<h4 class="entry-title"><a href="https://www.kimt.com/content/video/573394071.html">AARP releases stats on COVID-19 in nursing homes</a></h4><span class="entry-meta"></span>
      	  		</div>
      	  	</div>
        



        
						
			

											</div>
																										<div class="text-center" style="margin-bottom:30px">
						<div class="dfpWrapper">
							<div id='div-gpt-ad-right2' style="text-align:center">
								<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-right2'); });</script>
							</div>
						</div>
					</div>
																										<div class="tr-section">
													<div class="section-title title-before">
								<h1>Community Events</h1>
							</div>
																			<p><div data-cswidget="9804"> </div>

<script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js" > </script></p>
																													</div>
																										<div class="tr-section">
																			<p><script src="https://embed.secondstreetapp.com/Scripts/dist/optin.js" data-ss-embed="optin" data-design-id="262353" ></script>

</p>
																													</div>
																										<div class="text-center" style="margin-bottom:30px">
						<div class="dfpWrapper">
							<div id='div-gpt-ad-right3' style="text-align:center">
								<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-right3'); });</script>
							</div>
						</div>
					</div>
											

							</div>
						</div>
											</div>
				</div>
			</div>
<!-- Site Footer-->
<style>

@media only screen and (max-width: 768px) {
.site-footer {margin-bottom:50px}
}

@media only screen and (min-width: 769px) {
.site-footer {margin-bottom:90px}
}

</style>
						<footer class="site-footer">
				<div class="container">
					<div class="row">
						<div class="col-lg-3 col-md-6">
							<!-- Contact Info-->
							<section class="widget widget-light-skin">
								<h3 class="widget-title">Get In Touch With Us</h3>
								<p class="text-white">1751 Highway 52 North<br />Rochester, MN, 55901 USA<br /><br />112 N. Pennsylvania Ave.<br />Mason City, IA, 50401 USA<br /><br />135 East Williams St.<br />Albert Lea, MN, 56007 USA<br /><br />Rochester MN - 1-800-323-4883<br />Albert Lea MN - 507-369-0256<br />Mason City IA - 641-423-2540<br /><br /><a href=mailto:news@kimt.com"><font color="white">news@kimt.com</font></a> </p>
								<div class="addthis_inline_follow_toolbox"></div>
							</section>
						</div>
						<div class="col-lg-3 col-md-6">
							<section class="widget widget-light-skin">
								<h3 class="widget-title">Our Mobile App</h3>
								<a target="_blank" class="market-button apple-button mb-light-skin" href="https://itunes.apple.com/us/app/kimt-news-3/id1217561442?mt=8"><span class="mb-subtitle">Download on the</span><span class="mb-title">App Store</span></a>
								<a target="_blank" class="market-button google-button mb-light-skin" href="https://play.google.com/store/apps/details?id=com.heartland.kimt&hl=en"><span class="mb-subtitle">Download on the</span><span class="mb-title">Google Play</span></a>
							</section>
						</div>
						<div class="col-lg-3 col-md-6">
							<section class="widget widget-links widget-light-skin">
								<h3 class="widget-title">About Us</h3>
								<ul>
																			<li><a href="http://www.kimt.com/about-us">About Us</a></li>
																			<li><a href="http://www.kimt.com/about-us/kimt-jobs">Jobs</a></li>
																			<li><a href="http://www.kimt.com/about-us/meet-the-news-team">Meet The News Team</a></li>
																			<li><a href="http://www.kimt.com/about-us/management-and-sales">Management & Sales</a></li>
																			<li><a href="http://www.kimt.com/content/news/Closed-Captioning-Information-451643503.html">Closed Captioning</a></li>
																			<li><a href="/payments">Advertisers</a></li>
																			<li><a href="https://publicfiles.fcc.gov/tv-profile/kimt/applications-and-related-materials/">FCC Applications</a></li>
																	</ul>
							</section>
						</div>
						<div class="col-lg-3 col-md-6">
							<section class="widget widget-links widget-light-skin">
								<h3 class="widget-title">Usage and Legal</h3>
								<ul>
									<li><a target="_blank" href="https://publicfiles.fcc.gov/tv-profile/kimt">FCC Public Inspection File</a></li>
									<li><a target="_blank" href="https://publicfiles.fcc.gov/tv-profile/kimt/equal-employment-opportunity-records/">EEO Report</a></li>
									<li><a target="_blank" href="https://publicfiles.fcc.gov/tv-profile/kimt/programs-list/">Child Programming</a></li>
									<li><a target="_blank" href="http://www.kimt.com/content/news/451645913.html">Privacy Policy</a></li>
									<li><a target="_blank" href="http://www.kimt.com/content/news/451646363.html">Terms of Service</a></li>
									<li><a target="_blank" href="http://optout.aboutads.info/#!/">Ad Choices</a></li>

								</ul>
							</section>
						</div>
					</div>
					<hr class="hr-light mt-2 margin-bottom-1x">
					<p class="footer-copyright">
						All content © copyright KIMT. Copyright © 2020 Allen Media Broadcasting, LLC All Rights Reserved. Generated: 2019-12-31 11:00:03pm 
																			</p>
				</div>
			</footer>
								</div>

		<!-- Back To Top Button--><a class="scroll-to-top-btn" href="#top" title="Link to Top" aria-label="Link to Top"><i class="icon-arrow-up"></i></a>
		<!-- Backdrop-->
		<div class="site-backdrop"></div>

<div style="z-index:500;position:fixed;left:0;bottom:0;width:100%; background-color:#374250; text-align: center; background: rgb(55,66,80,0.8);" class="stickyfooter">
                 <div id='stickyfooter'><script>googletag.cmd.push(function() { googletag.display('stickyfooter'); });</script></div>
</div>

		<!-- JavaScript (jQuery) libraries, plugins and custom scripts-->
		<script src="https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js" integrity="sha384-DztdAPBWPRXSA/3eYEEUWrWCy7G5KFbe8fFjk5JAIxUYHKkDx6Qin1DkWx51bBrb" crossorigin="anonymous"></script>
		<script src="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/js/bootstrap.min.js" integrity="sha384-JZR6Spejh4U02d8jOt6vLEHfe/JQGiRRSQQxSfFWpi1MquVdAyjUar5+76PVCmYl" crossorigin="anonymous"></script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/velocity/1.5.0/velocity.js"></script>
		<script src="https://www.kimt.com/includes/scripts.min.js" type="text/javascript"></script>
		<script src="https://www.kimt.com/includes/theia-sticky-sidebar.js" type="text/javascript"></script>
		<script type="text/javascript">
			jQuery(document).ready(function() {
				jQuery('.sticky, .sidebar').theiaStickySidebar({
				// Settings
				additionalMarginTop: 100
				});
			 });
		</script>
		<script src="https://www.kimt.com/includes/jquery.cycle2.js" type="text/javascript"></script>
		<script src="https://www.kimt.com/includes/jquery.cycle2.center.min.js" type="text/javascript"></script>
		<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-59e8cc3c7413a9c9"></script> 
				<script type='text/javascript'>
		    var _sf_async_config = _sf_async_config || {};
		    /** CONFIGURATION START **/
		    _sf_async_config.uid = 64948; //CHANGE THIS
		    _sf_async_config.domain = 'www.kimt.com'; //CHANGE THIS
		    _sf_async_config.useCanonical = true;
		    _sf_async_config.sections = 'News Stories'; //CHANGE THIS
		    _sf_async_config.authors = ''; //CHANGE THIS
		    /** CONFIGURATION END **/
		    (function() {
		        function loadChartbeat() {
		            var e = document.createElement('script');
		            e.setAttribute('language', 'javascript');
		            e.setAttribute('type', 'text/javascript');
		            e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
		            document.body.appendChild(e);
		        }
		        var oldonload = window.onload;
		        window.onload = (typeof window.onload != 'function') ?
		            loadChartbeat : function() {
		                oldonload();
		                loadChartbeat();
		            };
		    })();
		</script>
											<script type="text/javascript"> (function(t) {var e = document.createElement("script");e.setAttribute("id", "tqflexsdksel"), e.setAttribute("fusionId", t), e.type = "text/javascript", e.src = "//api.traq.li/public/sdk/v03/sdk.js", e.async = !0, document.getElementsByTagName("head")[0].appendChild(e)}) (263); </script>
						</body>
</html>
		
			
